boot error - kde - can't restore boot loader

Boot, can’t login to user account. Just a black screen and return.

I removed the repos nvidia, pakman, and libdvd. Using the opensuse leap 15 dvd, an update install had no effect, boot loader error. opensuse dvd does an online update of itself.

Boot menu:
All grub menu opensuse versions won’t boot. boot to read-only snapshot successful. I was able to login to my kde root user account. I did an update.

Yast - boot loader → click ok.

‘error: enter this command’


opensuse leap 15 dvd -> update install -> same error on boot loader

I have the file. What do I need post here?

FYI, I’m about to reinstall opensuse leap 15, erase everything. I’m still doing online research.

The file from “save_y2logs” is for attaching to a bug report. Don’t try to post it here.

By black screen, you mean no login: prompt ? If so, I would try either this:

You may have no proper initrd, so something like this may be necessary:

 /usr/bin/dracut --logfile /var/log/YaST2/mkinitrd.log --force  /boot/initrd-4.12.14-lp151.23-default 4.12.14-lp151.23-default (!!  adapt to your kernel version !!)


grub2-mkconfig -o /boot/grub2/grub.cfg 

to re-generate grub config, .
but I’m not sure this will work from a read-only snapshot.**
If you cannot do this from the snapshot, you may have to use chroot from a live cd as explained here:
important: replace “update-grub” (Debian specific command) with grub2-mkconfig -o /boot/grub2/grub.cfg](

Edit: this won’t work from a snapshot, obviously.

I’ve messed up grub on occasions and what I do is use the install usb to do an upgrade and reinstall grub. Our problems may be different but this has always worked for me and is, at least, worth a try before a full reinstall.
You probably know that you need full iso or net install to upgrade, not a live cd.

kde root user account 


I’m sorry, but … sigh. I’m not going to repeat my previous responses to your issues re. this …

Re. snapshots: Open a console

sudo snapper list

Pick the indexno of the snapshot, replace #### by that indexno, just before the issue started, and do

sudo snapper rollback ####

I tried an upgrade install that didn’t work. I’v done this many times to fix the boot loader.

I did that. The last entry was x81. I rolled back to x75. After about 3 reboots, I was able to update the system to a current update. :slight_smile:

Thanks for the assist…