Bond0 interface - WLAN ping extremely unstable between 1...5000ms.

Hello everyone, it is my first post on forum, it is nice to join the community.
I use linux many years therefore have some experience with.Currently it is OpenSuse 42.3, with gnome GUI.
My PC is old Dell Inspiron 1720 with SSD (2x2,5Ghz + 4GB RAM), that still works pretty quick and I don’t want to change.
This is connected with Asus AP, expensive gaming model, very fast.All other devices (smartphones, NAS, TV) are working with it like a charm.

I have serious problems with stability of my WiFi connection.The WiFi connection itself is good and don’t break up, but packets going from my PC (192.168.1.34) over WiFi to AP WiFi interface 192.168.1.1 (it is Gateway address) are traveling between 1ms…4900ms, many get lost (10-20%).This isn’t allways the case, there are at the same day hours, while it works perfectly, and these when it doesn’t work any good.
The configuration is :
eth0 and wlan0 interfaces are enslaved to bond0 interface, which uses DHCP to get its LAN IP, and are able to work parallel, it was used so.

So, there are 2 situations :
a)ping 192.168.1.1 made 3000 times gives avg time 3ms and no lost packets, no DUPs (inspiron CPU use 3…5%)
b)ping 192.168.1.1 made 3000 times gives avg time 339ms 15% lost packets, 11 DUPs (inspiron CPU use 3…5%).Parallel pinged inspiron interface 192.168.1.34 from inspiron console itself is stable - average about 0.1ms.

Daytime doesn’t make any difference, it is totally random, but once this begins, it stay for hours slow like snail, or until I reboot Inspiroon PC.
All offline apps are working quick, so it is not CPU overload.
I have second Dell vostro laptop, using OpenSuse Leap 15.3 and WLAN and these ping 192.168.1.1 times are very short: 2…4ms all the time, even while Inspiron bounces, so it is NOT AP problem.Similar ping tests on smartphones were also very good, max 5ms.

Inspiron config :


# uname -r
4.4.180-102-default


# route -n
Kernel IP routing table                                                                    
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface              
0.0.0.0         192.168.1.1     0.0.0.0         UG    0      0        0 bond0              
192.168.1.0     0.0.0.0         255.255.255.0   U     0      0        0 bond0


# ifconfig                                                          
bond0     Link encap:Ethernet  HWaddr 00:1D:09:CB:93:46                                    
          inet addr:192.168.1.34  Bcast:192.168.1.255  Mask:255.255.255.0                  
          UP BROADCAST RUNNING MASTER MULTICAST  MTU:1500  Metric:1                        
          RX packets:97058 errors:0 dropped:16417 overruns:0 frame:0                       
          TX packets:63082 errors:0 dropped:0 overruns:0 carrier:0                         
          collisions:0 txqueuelen:1000                                                     
          RX bytes:51082879 (48.7 Mb)  TX bytes:9391781 (8.9 Mb)                           
                                                                                           
eth0      Link encap:Ethernet  HWaddr 00:1D:09:CB:93:46                                    
          UP BROADCAST SLAVE MULTICAST  MTU:1500  Metric:1                                 
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0                               
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0                             
          collisions:0 txqueuelen:1000                                                     
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)                                           
          Interrupt:17                                                                     
                                                                                           
lo        Link encap:Local Loopback                                                        
          inet addr:127.0.0.1  Mask:255.0.0.0                                              
          UP LOOPBACK RUNNING  MTU:65536  Metric:1                                         
          RX packets:18 errors:0 dropped:0 overruns:0 frame:0                              
          TX packets:18 errors:0 dropped:0 overruns:0 carrier:0                            
          collisions:0 txqueuelen:1                                                        
          RX bytes:1508 (1.4 Kb)  TX bytes:1508 (1.4 Kb)                                   
                                                                                           
wlan0     Link encap:Ethernet  HWaddr 00:1D:09:CB:93:46                                    
          UP BROADCAST RUNNING SLAVE MULTICAST  MTU:1500  Metric:1                         
          RX packets:97058 errors:0 dropped:0 overruns:0 frame:0                           
          TX packets:63082 errors:0 dropped:0 overruns:0 carrier:0                         
          collisions:0 txqueuelen:1000                                                     
          RX bytes:51082879 (48.7 Mb)  TX bytes:9391781 (8.9 Mb) 


# cat /etc/sysconfig/network/ifcfg-bond0 
BONDING_MASTER='yes'
BONDING_MODULE_OPTS='mode=0 miimon=100'
BONDING_SLAVE0='wlan0'
BONDING_SLAVE1='eth0'
BOOTPROTO='dhcp'
BROADCAST=''
DHCLIENT_SET_DEFAULT_ROUTE='yes'
ETHTOOL_OPTIONS=''
IPADDR=''
MTU=''
NAME=''
NETMASK=''
NETWORK=''
REMOTE_IPADDR=''
STARTMODE='auto'
PREFIXLEN='24'


# cat /etc/sysconfig/network/ifcfg-wlan0 
BOOTPROTO='none'
STARTMODE='auto'
WIRELESS_ESSID='druid'
WIRELESS_AUTH_MODE='psk'
WIRELESS_WPA_PSK='sda9332Ke90kd#$%'
BROADCAST=''
ETHTOOL_OPTIONS=''
IPADDR=''
MTU=''
NAME=''
NETMASK=''
NETWORK=''
REMOTE_IPADDR=''
WIRELESS_AP=''
WIRELESS_AP_SCANMODE='1'
WIRELESS_BITRATE='auto'
WIRELESS_CA_CERT=''
WIRELESS_CHANNEL=''
WIRELESS_CLIENT_CERT=''
WIRELESS_CLIENT_KEY=''
WIRELESS_CLIENT_KEY_PASSWORD=''
WIRELESS_DEFAULT_KEY='0'
WIRELESS_EAP_AUTH=''
WIRELESS_EAP_MODE=''
WIRELESS_FREQUENCY=''
WIRELESS_KEY=''
WIRELESS_KEY_0=''
WIRELESS_KEY_1=''
WIRELESS_KEY_2=''
WIRELESS_KEY_3=''
WIRELESS_KEY_LENGTH='128'
WIRELESS_MODE='Managed'
WIRELESS_NICK=''
WIRELESS_NWID=''
WIRELESS_PEAP_VERSION=''
WIRELESS_POWER='no'
WIRELESS_WPA_ANONID=''
WIRELESS_WPA_IDENTITY=''
WIRELESS_WPA_PASSWORD=''

I have no clue, what is wrong.
Please give me some advice, I don’t want to spend a 2 weeks with 10 hours per day searching for solution, my knowledge is too small.
P.S. As I had parallel WiFi and eth0 cable connection, during FTP upload to local NAS speed varied betweed 5MB…18MB per second, once it was using WiFi, once eth0, and once both parallel, without any user intervention.

regards, c.

Of course I’m going to have to mention that your openSUSE version is many, many years out of date which means your system is running on a very old kernel and your system is extremely vulnerable to a multitude of well known exploits. While you’re online, anyone might scan your machine and within a short time “own” you a number of different ways. You should seriously consider making plans to upgrade your machine to a currently supported version of openSUSE ASAP.

Your system is the first time I’ve seen/heard of a machine set up bonding your ethernet and WiFi network interfaces, and the bonding mode is “round robin” which means that your sessions are designed to fail 50% of the time if you’re connected using only one of your two physical network devices (wireless and wired). Depending on the router(s) each network is connected to, you will also have session identification problems with whatever server you’re connected to even when both network connections are enabled.

In other words,
I wouldn’t recommend your network bonding setup for a typical User’s machine… maybe in a different scenario but not this one.

TSU