Im trying to run BOINC, i downloaded the .sh from Boinc website, its latest version. Installed it and when doing ./boinc this is what i get (also tried ./run_manager):

gabriel@dhcppc0:~/Documents/BOINC> ./boinc
16-Sep-2009 17:33:00 —] Starting BOINC client version 6.6.36 for x86_64-pc-linux-gnu
16-Sep-2009 17:33:00 —] log flags: task, file_xfer, sched_ops
16-Sep-2009 17:33:00 —] Libraries: libcurl/7.18.0 OpenSSL/0.9.8g zlib/1.2.3 c-ares/1.5.1
16-Sep-2009 17:33:00 —] Data directory: /home/gabriel/Documents/BOINC
16-Sep-2009 17:33:00 —] Processor: 4 AuthenticAMD AMD Phenom™ 9500 Quad-Core Processor [Family 16 Model 2 Stepping 2]
16-Sep-2009 17:33:00 —] Processor features: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 ht syscall nx mmxext fxsr_opt pdpe1gb rdtscp lm 3dnowext 3dnow constant_tsc rep_good nopl pni monitor cx16 popcnt lahf_lm cmp_legacy svm extapic cr8
16-Sep-2009 17:33:00 —] OS: Linux:
16-Sep-2009 17:33:00 —] Memory: 1.96 GB physical, 2.01 GB virtual
16-Sep-2009 17:33:00 —] Disk: 271.75 GB total, 232.06 GB free
16-Sep-2009 17:33:00 —] Local time is UTC -4 hours
16-Sep-2009 17:33:00 —] No CUDA devices found
16-Sep-2009 17:33:00 —] No coprocessors
16-Sep-2009 17:33:00 —] Not using a proxy
16-Sep-2009 17:33:00 —] No general preferences found - using BOINC defaults
16-Sep-2009 17:33:00 —] Preferences limit memory usage when active to 1002.75MB
16-Sep-2009 17:33:00 —] Preferences limit memory usage when idle to 1804.94MB
16-Sep-2009 17:33:00 —] Preferences limit disk usage to 10.00GB
16-Sep-2009 17:33:29 —] [error] GUI RPC bind to port 31416 failed: 98
gstate.init() failed: -180

I think it means you have to open port 31416 in your firewall/router so the program can communicate to the clients - seti@home, etc.?

it looks like it cant bind to the local port rarther then the remote port
seems odd tho
have you got ppnp enabled

I’ve been running boinc for a very long time. When I got a couple of updates into 11.1, it would no longer connect to localhost. But that is just the gui manager part. The client continues to run in the background.

Same thing happened with my test machine. BOINC ran all the way through 11.2 M3 and some update killed it. This forum is way more help than the boinc forum. I just hope someone here has found a solution. :wink:

I am having the same trouble. I upgraded to 11.2 and get that exact same error. I disabled the firewall and still get the same error. Can anyone help?

The 98 above says the port is in use - somebody else got it first.


lsof -i:31416

and it should tell which program has the port.

From my machine

gwb@linux-w12j:~> lsof -i:31416
boinc   4316  gwb    6u  IPv4  18611      0t0  TCP localhost:xqosd (LISTEN)

and BOINC has been churning out units since 11.2 upgrade.

Did you look at this thread?

The problem is that Boinc client is running, stop it and try again.