BOGUS LENGTH in write keyboard desc, expected 5608, got 5624

When I’m drawing in GIMP on my tablet Wacom Bamboo Fun A5 Wide, X Server suddenly crashes or freezes. Here is a log: #429473 - Pastie]( (this is a freeze log, when it crashes there are no messages about overflowing, and the BOGUS LENGTH is the last line in the log)

This happens when I press any buttons on keyboard. It may crash/freeze when I press Alt+Tab or when I press Ctrl+Alt or even when I change brush size with «» or «]».

I tried to install the newest NVIDIA driver from the repo, the newest Xorg with all other packets which are related to it. The newest glibc. All from official stable repos. But it doesn’t change. Some time ago this problem also appeared when I installed Factory builds from experimental repos. Then I switched off those repos and did «zypper dup», so all such packets were downgraded. But now I see that it doesn’t help. So I get back to the original xorg/glibc from the installation ISO. But now it doesn’t help, guess that some other libs must be downgraded, too. But I don’t know which exactly.

The problem occurs completely random after 20 mins — 3 hours of drawing in GIMP (I’ve also tried 2.6.2 from stable repo and 2.6.5 from factory, that doesn’t matter). All I can say, it happens when I press a key, key combination or a button on the tablet which simulates keystroke and I never got it when I don’t use the tablet (but it’s always connected to USB and works).

My hardware: Intel Core 2 Duo E6750, 2 Gb RAM, NVIDIA GeForce 8600GTS (don’t remember motherboard model and don’t know how to find it).
Software: OpenSuSE 11.1, GNOME. Also, in XFCE I get the same problem, so it’s not DE issue. Installed linuxwacom driver for tablet because OpenSuSE’s one works weird (when I touch the tablet’s surface and draw a line the cursor doesn’t move, it only moves when I move the pen above the surface).

xorg.conf: #429480 - Pastie](

As I see in google no one faced this trouble. At least, how can I test what exactly causes the crash and what to do with it? This is really annoying.

I can’t believe no one ever get this trouble. Where should I ask for help then except Xorg forums?

Anyone, please! What does this error mean? What can cause it? I’ve tried almost all, downgrading and upgrading alsa, nvidia driver, xorg, gimp, linuxwacom, nothing helps. It looks like this error is a thing no one should talk about. Many questions, no answers. All I found in google regarding this is about monitor switching on/off, laser mouse, alsa kernel driver and nvidia driver. But nothing about gimp and wacom. I tried gimp from stable 11.1 repo (which is very old) and latest 2.6.6. They cause lockups/crashes in the same way. So wacom driver does. I can’t say they are the problem because the same versions others use without problems. But they are related because without using the tablet and gimp system is relative stable. At least, I get no such lockups/crashes. And they occur always when gimps window is active (so I do something in it with the tablet and keyboard). Don’t know how to investigate better.

Please, help!

It seems that problem was semi-solved. I downgraded the kernel to the original ISO version ( and set «nv» video driver in xorg.conf. Then I painted in GIMP for about 5 hours without any crash or lockup. So I guess the bug is in kernel or nvidia proprietary driver. nv driver doesn’t support xv video output and because of this doesn’t suite my needs. Now I use nvidia proprietary driver and soon will try to paint for some hours to test the systems stability. Anyway, it looks more like a kernel bug (or something related to it, maybe some kernel modules, keyboard driver conflicting sometimes with wacom driver or such) than video. We’ll know soon.

The kernel update was issued recently (around March, 21) so may be not so many people got this bug.

Also, I tried to compile wacom.ko module with kernel sources (when I used updated kernel), it worked ok but the bug occurred the same way.

Thanks everyone who helped me ~_~

No one helped but never mind. The good thing is that it seems I solved the problem. The bad thing is that I don’t know what exactly caused such a serious and annoying bug. I tried almost all regressions from software to kernel, including NVIDIA drivers and uim. Nothing helped. So when I was ready to reinstall the system completely an idea had come. I created a new user with an empty profile (well, not exactly empty but close to it), logged in and ran GIMP only. Suddenly, the system was pretty stable and I painted about 2.5 hours without a single issue. That became interesting, so I continued my investigation.

As I mentioned above, that was neither drivers’ nor software fault. It was somewhere deeper in the system. Also, I tried to use XFCE earlier, but Xorg crashed the same way. So, there were two ways to solve this:

  1. to move all significant dirs to that clean profile, delete the primary profile and rename the new one;
  2. try to remove all system hidden dirs in the main profile to reset the settings.

I chose the second. Created the dir «config_backup» and moved there the following dirs:

Then I logged in to this main cleared profile and configured basic features (interface, keyboard and such). Then I drawed two hours without a fault. Seems like solved, but somewhere in that backed up configs there is a danger setting. Hope it will help wretched one who will curse Xorg and his keyboard for such crash/lockup. :slight_smile:

Well, it took up almost two weeks to fix the trouble. Also I hope it won’t get back.

> No one helped but never mind.

i guess no one could help…i sure couldn’t…

however, i’m sure that your “neither drivers’ nor software fault. It
was somewhere deeper in the system.” is not correct as i believe it
was not deep in the system…

in fact, by replacing major parts of “the system” and still having the
problem, but then replacing parts of your /home you proved it was
something peculiar in YOUR /home directory…which is technically NOT
even in “the system” but rather are your settings for your use of
“the system” only…

conclusion: “the multi-user system” was okay all along (any new user
would have had no problems), it was only YOUR somehow corrupted and/or
wrongly set settings causing a problem for ONE user, you.


Well, that was an incorrect statement about deep bug. I meant there was a very-system-deep setting in my profile that caused this error. Or, in other words, that was an unsuspected setting for something that has a deep bug somewhere in Xorg drivers or server itself. I can’t dig it further because there are 75 Mb of stuff in that dirs and I’m sort of exhausted fighting this bug. Maybe later I’ll try moving this dirs back to my homedir and try to catch it again. Anyway, just for info, do you know what dirs from the list above are common for GNOME and XFCE? I guess XFCE doesn’t use gconf but not sure about .metacity, .font*, .local and .config dirs.

eurekafag wrote:
> just for info, do you
> know what dirs from the list above are common for GNOME and XFCE?

no, but i personally would begin with some directories you did NOT
name above, namely:



To make things clear: I didn’t move any other dirs except mentioned above. Well, I deleted some dirs where settings for programs I’ve removed already are located. Don’t think they are related. Also, when I suspected gimp, I deleted it’s whole dir (.gimp-2.6) and that didn’t help. And I have no .wacom dir.