Blurred text in Opesuse 13.1

Hello All,

I recently did a clean installation of suse 13.1 on my desktop, but I am having some problems with blurry text in all the applications.

I know it is not a monitor issue, because sometimes when I pass the cursor over the text, or while I’m typing, text appears clear(er), and anyway other graphics is crystal clear.

Current system text settings are:

  • Liberation font 10 pts
  • Force character resolution at 96 dpi
  • Force anti-aliasing

My only guess is that it might have something to do with the graphic card. I had some problems installing the drivers, I have a GeForce GTS 250, which is quite old, these below are the packages I installed:

  • nvidia-computeG03-331.38-23.1.x86_64
  • nvidia-glG03-331.38-23.1.x86_64
  • nvidia-texture-tools-2.0.6-23.1.3.x86_64
  • x11-video-nvidiaG03-331.38-23.1.x86_64
  • nvidia-gfxG03-kmp-desktop-331.38_k3.11.6_4-23.1.x86_64
  • libdrm_nouveau2-2.4.46-3.2.2.x86_64
  • xf86-video-nv-2.1.20-7.1.2.x86_64

I know there’s something not quite right with the installation because I do not get the nVidia logo displayed at startup, while it happens with all my other linux computers.
The nouveau package in the list sounds souspicious to me, but if I try to remove it, I got a message of a broken link to a Mesa package.

Any help greatly appreciated

You have the wrong driver version installed for your card. The G03 driver is for GeForce 8xxx and newer GPUs.

You need to install the legacy driver for your card, located here:

That’s not true.
The GeForce GTS 250 (GeForce 200 series) is newer than the GeForce 8 series and therefore supported by the G03 driver.
In fact that legacy driver you linked to would not support the card, and would not even work on openSUSE 13.1 because of the too new kernel and X.

It’s normal that you don’t get the nvidia logo, and it’s normal that nouveau is installed.
So leave it there.

Could you upload the file /var/log/Xorg.0.log to and post a link to see if the nvidia driver is actually in use?

You do not mention which desktop you are using.

If it is KDE, they try disabling desktop effects. Perhaps you will prefer the appearance that way (as I do).

@ Wolfi 323: the content of my Xorg.0.log is at

@ nrickert: I’m using KDE, and actually you are right! Disabling desktop effects does make the blurred text disappear! I never had this problem before… Is there any chance I can have again readable text and desktop effects as I had in the previous version of opensuse?


OK, the nvidia driver is working.
It determines your monitor’s resolution as 1360 x 768, is that the native size of your display?

Hm, I have no idea why desktop effects should cause blurred text.
Do you maybe have set the wrong resolution in “Configure Desktop”->“Display and Monitor”? (there’s at least a KScreen effect in desktop effects)

Another possible cause I think could be the subpixel hinting setting in “Application Appearance”->“Fonts”. But then it shouldn’t make a difference if desktop effects are enabled or disabled I guess.

You could of course try to switch off each effect separately to find out which one is causing the blurred fonts.

A small update on what I said above: I played a bit with the KDE menu for the desktop effects, my conclusion as not-expert is that the problem has something to do with the OpenGL; as if I switch to XRender I got the text accurately rendered, even if, of course, I loose most of the effects.

Have you added yourself to the “video” group? My understanding is that opengl support with the nvidia driver only works for members of that group.

You can type


in a terminal window to see what groups you are in.

Shouldn’t be necessary anymore since the systemd update in December. logind should grant the user the necessary rights to access the nvidia card.

To check whether it’s working, install “Mesa-demo-x” and run:

glxinfo | grep render

It should say “Direct rendering: Yes”. If there’s an error message about “permission denied” and “Direct Rendering: No”, you’re suffering from that problem and have to add the user to the “video” group.

Although it cannot harm in any case of course.

Thanks for correcting, wolfi.

I quickly looked up the nVidia stuff, and saw the GTS and the 2 listed in legacy, put it together with his mention of “old card”, and made the mistake of thinking it was one of the older cards.

Glad you knew better and spotted that.

As for the nVidia logo, it shows up with mine (my card uses the G02 driver).

This can be configured. The driver README states this in Appendix B, X Config Options:

Option “NoLogo” “boolean”
Disable drawing of the NVIDIA logo splash screen at X startup. Default: the logo is drawn for screens with depth 24.

I just solved the issue:

in the nVidia server settings, the following option was ticked: Enable FXAA, which I understand enables the fast approximate anti aliasing. Unticking the box gave me back both the clear text and the desktop effects.

Thanks to you all for helping me!

Ah! This rings a bell somewhere in the back of my head.
I’m sure I already read about problems with this option, and to better turn it off with KDE’s desktop effects… (I think it was in the KDE forums)
And there are even bug reports about that:

Thanks for telling!
This might help others as well maybe. :slight_smile: