Bluray Writer some times fails to load disc

I have occasionally problems loading DVDs.
It is only on a very few DVDs, and most discs load fine. My Bluray Writer is blinking and I can feel the unit is moving some parts around in there, but then… nothing and blinking stops. When the unit is successful with reading I feel the disc spinning and a notification pop up and the disc can then be mounted.

I disconnected the device and plugged in into my Windows laptop. It had no problem loading the disc what so ever.
Today I put in a DVD it had problem loading yesterday, it took a bit longer than usual, but it was able to load it up eventually this time. I then continued with another DVD I also had problem loading yesterday, and that one would still not work.

Why is it that it will not load the DVD in some occasion? No disc inserted it says.
I have tried disconnection the USB Bluray writer, and connected it, but still it will not load the disc.

Samsung Blu-Ray Writer SE-506AB
USB 2.0, BD-R: 6x, BD-R DL: 6x, DVD±R: 8x, Slim, BLACK

Is there some logs I can look to see what the problem is?

I think it was a coincident that I got that one DVD loading on Windows. The last DVD I have tried several times on both Windows and Linux and still it will not load. So I don’t think Linux is the problem, but rather the Bluray Writer unit. Strange though considering there is no defect on the DVD, its just old.
Edit: well it finally did load on Windows… strange.