Bluetooth works with local apps, but not with any Web browsers.

I first posted this in “Wireless” and 68 looked at it, but no one replied. So, I’ll try it here…

I bought a Plugable Bluetooth USB Adapter and plug it into my oS 12.3 laptop. It worked right away without having to do anything. I can play music from Juk, Amorak, or any app. However, I can’t get any Web browser to use it at all. Chrome, FireFox, Opera, or Konquor all refuse to send anything through bluetooth. They all play on the crappy laptop speakers.

Any ideas why or what to do about it?

BTW, all versions of everything up-to-date. Also, Plugable thinks it’s a Linux problem because it works in some places. I’ve also sent to Chrome help and haven’t received an answer there either.


I don’t have such a device, but you need to set it up in Bluetooth first. Then, you must configure a mobile broadband setup in Network Manager. What steps have you taken?

Thank You,

  1. If I understand you correctly, you’re referring to a bluetooth audio device, and the fact that some apps don’t appear to be able to use it?

  2. Are you using KDE or Gnome, or…?

It’s likely that you need to configure ALSA or pulse-audio first…

SDB:Bluetooth headphones - openSUSE

openSuSE 12.1, VoIP via Ekiga and a Bluetooth headset | Turning it off and on again

This is Arch-Linux orientated, but bound to have some useful tips:

I am using KDE in oS 12.3. I have Bluetooth configured and it works. Well, it works with Juk and other audio players. I can play music to the BT boombox without any problem. So, I assuming that it is configured correctly or it would play from Juk.

However, any audio that I play in a Web browser doesn’t send to the BT boombox. It plays only on the laptop’s speakers. This is true for Chrome, FireFox, Opera, and Konqueror.

I’m not sure I understand the network configuration question. I didn’t have to do anything there to get it working in Juk etc. The BT device is showing in Networks and it’s active and connected.


I think that was a misunderstanding on James’ part.

I can only guess at this based on the following thread, and the fact that I don’t have this hardware to play with

Madsonic Forum • View topic - [Solved] Bluetooth on Laptop

Do you have the ‘alsa-oss’ package installed?

I looked at the links you guys gave and lots of interesting ideas, but they all talk about getting BT to work period. It’s working, but just not in Web browsers. I don’t see anything on that.


Yes, I was confused. The top of the message mentioned wireless, which is all it took. Further, before my reply, I was able to share the Internet to my laptop using bluetooth from my smart phone and openSUSE 13.1.

Thank You,

I’m using KDE 4.10 with openSUSE 12.2 so don’t have a great deal of experience with PulseAudio, nor am I an audio guru. Hopefully, someone with the knowledge will chime in to assist further. While researching this issue, I note lots of threads reporting PA issues with Chrome and Firefox browsers (which have only recently gained PA support, and problems continue to be reported).

From this thread
Gentoo Forums :: View topic - pulse audio: each app steals audio device? (solved)
I note the following mentioned

And yes, some programs have PulseAudio support alongside ALSA support, but do not automatically use PA without the user manually setting it to that (e.g mplayer with -ao pulse as far as I know). In most cases it’s not too much trouble to just have them be re-routed by alsa-plugins[pulseaudio], but less optimal – some PA features may not work or work less well if going through ALSA API first; in particular things that the program itself could make use of out of PA API, probably e.g things like using bigger buffers when appropriate for power saving, etc.

To clear things up about “ALSA”, when we talk of ALSA it could be different things - ALSA the kernel audio infrastructure, or the userspace ALSA API for application use (media-libs/alsa-lib). Direct PulseAudio goes application→PA→alsa-lib→kernel ALSA→hardware, while ALSA using APIs with PulseAudio will have to go application→alsa-lib→alsa pulse plugin→PA→alsa-lib→kernel ALSA→hardware. The API from alsa-lib used by ALSA application and by PulseAudio is a bit different, in particular PulseAudio leverages much of the more advanced ALSA features and the exposing API, which is also what caused a lot of initial teething problems - nothing else had really excercised those things before PulseAudio and many alsa kernel drivers didn’t work properly for those needs initially.

I would start by launching pavucontrol (the PulseAudio Control), and see if any settings need to be adjusted there first, and make sure that you have all the required alsa packages (including alsa-plugins-pulse).

Did you ever find a solution to this?
I am having the same problem.
I use Pulse and can play local media but youtube etc gets played through laptop speakers as opposed to BT speakers.