Bluetooth worked in live boot but doesn't in install

Hi, I’m a new user of opensuse, although have been using Linux for years.

When I tried the live boot version of tumbleweed, bluetooth was working. Then I installed the dvd edition with kde desktop. Unfortunately, bluetooth isn’t working now.

The bluetooth chip is rtl8723be. Some of you might know that this is a problematic chip, and doesn’t work on many distros. There is another issue with this chip that the wifi signal is shown less. This can be fixed(and I fixed it) by setting the ant_sel option, and sometimes requires installing a driver provided here . But I didn’t have to install that driver, it worked by simply setting that option.

So what should I do to get bluetooth working? should I try the above driver? has anyone fixed this?

Here are some details that might be helpful

aditya@linux-vrer:~> dmesg|grep -i bluetooth
    5.298890] usb 1-4: Product: Bluetooth Radio 
   12.092008] Bluetooth: Core ver 2.22
   12.092043] Bluetooth: HCI device and connection manager initialized
   12.092049] Bluetooth: HCI socket layer initialized
   12.092053] Bluetooth: L2CAP socket layer initialized
   12.092068] Bluetooth: SCO socket layer initialized
   12.590789] Bluetooth: HCI UART driver ver 2.3
   12.590793] Bluetooth: HCI UART protocol H4 registered
   12.590795] Bluetooth: HCI UART protocol BCSP registered
   12.590796] Bluetooth: HCI UART protocol LL registered
   12.590798] Bluetooth: HCI UART protocol ATH3K registered
   12.590799] Bluetooth: HCI UART protocol Three-wire (H5) registered
   12.590847] Bluetooth: HCI UART protocol Intel registered
   12.590880] Bluetooth: HCI UART protocol Broadcom registered
   12.590882] Bluetooth: HCI UART protocol QCA registered
   12.590884] Bluetooth: HCI UART protocol AG6XX registered
   12.590885] Bluetooth: HCI UART protocol Marvell registered
   14.542002] Bluetooth: hci0: rtl: examining hci_ver=06 hci_rev=000b lmp_ver=06 lmp_subver=8723
   14.542009] Bluetooth: hci0: rtl: loading rtl_bt/rtl8723b_config.bin
   14.561522] bluetooth hci0: Direct firmware load for rtl_bt/rtl8723b_config.bin failed with error -2
   14.561526] Bluetooth: hci0: Failed to load rtl_bt/rtl8723b_config.bin
   14.561527] Bluetooth: hci0: rtl: loading rtl_bt/rtl8723b_fw.bin
   14.576912] Bluetooth: hci0: rom_version status=0 version=1
   14.576916] Bluetooth: cfg_sz 0, total size 22496
   18.721559] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
   18.721560] Bluetooth: BNEP filters: protocol multicast
   18.721565] Bluetooth: BNEP socket layer initialized
   41.450920] Bluetooth: RFCOMM TTY layer initialized
   41.450932] Bluetooth: RFCOMM socket layer initialized
   41.450948] Bluetooth: RFCOMM ver 1.11
  164.908520] Bluetooth: hci0 urb ffff9f8ac8968300 failed to resubmit (113)
  175.905912] Bluetooth: hci0 urb ffff9f8afb94fa80 failed to resubmit (113)

Once again, note that it did work with the live boot version. thanks!

I just had trouble getting my Bluetooth operational. The following link was a discussion with ‘oldcpu’ and the information helped me. The pulse audio fix was the final fix for me -but- you have to make sure you have the bluedevil5 driver installed. Check what software is installed pertaining to Bluetooth and seek help from ‘oldcpu’.

Btw my problem is not with audio, I can’t use my bluetooth at all. bluedevil5 is installed.

[NEW] Controller 48:E2:44:B1:D8:86 linux-vrer [default]
[bluetooth]# power on
Failed to set power on: org.bluez.Error.Failed

Here is some device info

[bluetooth]# show 48:E2:44:B1:D8:86
Controller 48:E2:44:B1:D8:86
        Name: linux-vrer
        Alias: linux-vrer
        Class: 0x000000
        Powered: no
        Discoverable: no
        Pairable: yes
        UUID: Headset AG                (00001112-0000-1000-8000-00805f9b34fb)
        UUID: Generic Attribute Profile (00001801-0000-1000-8000-00805f9b34fb)
        UUID: A/V Remote Control        (0000110e-0000-1000-8000-00805f9b34fb)
        UUID: OBEX File Transfer        (00001106-0000-1000-8000-00805f9b34fb)
        UUID: Generic Access Profile    (00001800-0000-1000-8000-00805f9b34fb)
        UUID: OBEX Object Push          (00001105-0000-1000-8000-00805f9b34fb)
        UUID: PnP Information           (00001200-0000-1000-8000-00805f9b34fb)
        UUID: A/V Remote Control Target (0000110c-0000-1000-8000-00805f9b34fb)
        UUID: IrMC Sync                 (00001104-0000-1000-8000-00805f9b34fb)
        UUID: Audio Source              (0000110a-0000-1000-8000-00805f9b34fb)
        UUID: Audio Sink                (0000110b-0000-1000-8000-00805f9b34fb)
        UUID: Vendor specific           (00005005-0000-1000-8000-0002ee000001)
        UUID: Message Notification Se.. (00001133-0000-1000-8000-00805f9b34fb)
        UUID: Phonebook Access Server   (0000112f-0000-1000-8000-00805f9b34fb)
        UUID: Message Access Server     (00001132-0000-1000-8000-00805f9b34fb)
        Modalias: usb:v1D6Bp0246d052B
        Discovering: no

aditya@linux-vrer:~> sudo rfkill list
[sudo] password for root: 
0: phy0: Wireless LAN
        Soft blocked: no
        Hard blocked: no
3: hci0: Bluetooth
        Soft blocked: no
        Hard blocked: no

Have you done a detailed comparison between the ‘live Tumbleweed’ and the ‘installed Tumbleweed’ wrt the detailed printouts you have used ? How about kernel versions ? Are they different? If kernels different, maybe check change history to see if that explains the different functional behaviour. The same suggestion applies to bluedevil versions (if different).

Having it work in a live setup and not in an installed setup gives you access to information most (all ? ) of us do not have wrt any comparison.