Bluetooth USB-dongle not detected on 11.1

I just installed openSUSE 11.1 on older desktop machine.

Got a USB-bluetooth (dongle) that works fine on other Linux
distros, on this exact same hardware (I multi-boot various
OSes), but fails to get supported on openSUSE. I installed
KDE’s kdebluetooth package, but when I right-click, it
shows ‘no bluetooth adapter’ when I hover there.

I ran a hardware detector, whichs FINDS the dongle, but
probably some low-level piece of bluetooth support isn’t
installed or isn’t functioning correctly.

My USB-hardware is ‘older’, so it’s only 1.2, not 2.0 USB
(but that’s cool with other Linux’s).

Ideas on what software to run/install that I might be


I had this problem when I tried KDE. If I remember correctly I went into Yast > Services and enabled bluetooth. After that I installed anything and everything I thought might work in the kdebluetooth, bluez, and obex packages. I restarted and it started working fine, I believe.

Yes, thanks, you are correct that there was
a ‘service’ (under SYSTEM->System Services(run-level))
for bluetooth that was not enabled.

I now have it enabled.

But, that did NOT solve it.

So, as you indicated, I too started just started installing
everything related to the search word ‘bluetooth’.
[Sigh…that even got me the other kernel (default), when
I mistakenly included some ‘old drivers for dongle’ that
had ‘default’ as part of the name. So, after another battle
cleaning up the mess made from that, I installed some
other libXXXX that say they are bluetooth-related.]

And, it is STILL not working.

[Rat-sh*t! AARRGGHHHHHH!!! Guess I’ll just have
to wander back to my Debian-based distro to do my
bluetooth-related stuff. I can’t figure this out.
You’d THINK they’d just create some template package
containing whatever is needed to get bluetooth
to work, but that hasn’t happened yet, near as I
can tell.]>:(

Hmm… maybe this will help:
Bluetooth - openSUSE Forums

Post back in case of any success!

No, the KDE-4 info isn’t really relevant, because I see the
same problem under KDE-3.x.

Meanwhile, I DID NOTICE some new updates to various ‘bluetooth’
related packages in the last few weeks. So, I applied everything,
and then tried once again to get my Bluetooth-dongle to
get seen as the local bluetooth adapter.

But, alas, the symptoms are exactly as they were before. :frowning:

So, again, if anyone has any other ideas of something to try
please let me know. [Meanwhile, I’m doing my bluetooth-related
stuff under both MEPIS (Debian-based Linux) and Windows-Vista.]

I finally made some significant progress, based on:
openSUSE 11.1 KDE3 Bluetooth solution - openSUSE Forums

So, there DOES seem to be a problem that KDE-4.x
brings in stuff that breaks/confuses bluetooth support,
even when NOT using KDE-4.x! (I had been logging in
to KDE-3.x exclusively for the bluetooth stuff.)

So, after specifying that extra repo (referred to in that
other thread), I did manage to get my USB-bluetooth adapter
to be able to browse my bluetooth cellphone, and get the
list of services available.

That said, the KDE-3-based widget in the systray is
broken…it erroneously stays white/blank and can
NOT show the bd-addr of my USB-adapter dongle or
even indicate that one is present.

Sigh…two steps up and one step back. Closer, but
no cigar.

[So, once again, I wander back to my Debian-based
distro(s), where bluetooth works better.]

Finally DID get it working, after hacking even more.

Now, my BT-adapter does initialize and go into a
‘connectable’ state. So, now I’ll go test the
Java-based BT-code I’ve been developing elsewhere,
and see if it works ok here.


But, that only lasted for maybe an hour, and then it
reverted to the EARLIEST broken symptom again…the
adapter now does NOT get seen (again).

It no doubt has to do with all these crazy EXTRA KERNELS
that we don’t ask for, but get anyway. You know, trace,
base,kernel-of-the-day, modify your menu.lst, whether you
want us to or not.

Way too many people hacking your repos and kernels and whatnot,
all with different agendas, and the only agenda in common
is that you break the functionality of the system.

I will NOT be back again anytime soon. >:(