Bluetooth stops working after installing bcm43xx firmware

Hi All,
hope this message finds you fine, Im having an annoying problem here, after the reinstallation of opensuse, bluetooth works fine, i can connect my cell phone and logitech mouse normally, as soon as i install the bcm43xx from the scrtipt included in /usr/sbin/ bluetooth stops connecting to devices, it can find tem when searching but the forward button is dimmed.

when i try hcitool scan,= it successfully finds the device,
hcitool cc xxxxxxx it reports an I/O error,
pleeeease anyone could help me,

Thanks in advance

If I don’t post this, the next person will. So here it is.
Read the sticky posts at the top of the forum. Search the forum for threads of the same nature as yours. (there are tons of broadcom threads)
Post the output from the command in the sticky posts here.

Thnx rod, i solved it, everything worked fine when i removed the b43 driver and installed broadcom’s sta driver from here - 802.11 Linux STA driver

just followed the readme with a few twweaks for opensuse.

Good to hear it!

Actually, you should file a bug report on this, in a nutshell, there is a module parameter for this problem:

 modinfo b43
filename:       /lib/modules/
firmware:       b43/ucode9.fw
firmware:       b43/ucode5.fw
firmware:       b43/ucode15.fw
firmware:       b43/ucode14.fw
firmware:       b43/ucode13.fw
firmware:       b43/ucode11.fw
firmware:       FW13
license:        GPL
author:         Gábor Stefanik
author:         Michael Buesch
author:         Stefano Brivio
author:         Martin Langer
description:    Broadcom B43 wireless driver
srcversion:     0C52DEBC020AE11CF13E725
alias:          pcmcia:m02D0c0476f*fn*pfn*pa*pb*pc*pd*
alias:          pcmcia:m02D0c0448f*fn*pfn*pa*pb*pc*pd*
alias:          ssb:v4243id0812rev10*
alias:          ssb:v4243id0812rev0F*
alias:          ssb:v4243id0812rev0D*
alias:          ssb:v4243id0812rev0C*
alias:          ssb:v4243id0812rev0B*
alias:          ssb:v4243id0812rev0A*
alias:          ssb:v4243id0812rev09*
alias:          ssb:v4243id0812rev07*
alias:          ssb:v4243id0812rev06*
alias:          ssb:v4243id0812rev05*
depends:        pcmcia,mac80211,ssb,compat_firmware_class,mmc_core,cfg80211
vermagic: SMP preempt mod_unload modversions 
parm:           bad_frames_preempt:enable(1) / disable(0) Bad Frames Preemption (int)
parm:           fwpostfix:Postfix for the .fw files to load. (string)
parm:           hwpctl:Enable hardware-side power control (default off) (int)
parm:           nohwcrypt:Disable hardware encryption. (int)
parm:           hwtkip:Enable hardware tkip. (int)
parm:           qos:Enable QOS support (default on) (int)
**parm:           btcoex:Enable Bluetooth coexistence (default on) (int)**
parm:           verbose:Log message verbosity: 0=error, 1=warn, 2=info(default), 3=debug (int)
parm:           pio:Use PIO accesses by default: 0=DMA, 1=PIO (int)

but according to the output, it should be there by default.

Try loading b43 with:

modprobe b43 -v btcoex=1

If this doesn’t help. file a bug report on