Bluetooth stopped working after zypper dup today

I’m using gnome 40 with an up-to-date tumbleweed on my laptop. After a routine zypper dup today bluetooth stopped working. Bluetooh was listed as “off” when I clicked on the upper right corner of the desktop UI and there was no option to turn it on. The problem seemed to be identical to one described here: https://bugs.launchpad.net/ubuntu/+source/gnome-shell/+bug/1738838
I tried running rfkill and got this result:

1 wlan phy0 unblocked unblocked
5 bluetooth hci0 unblocked unblocked

When I rolled back to a snapshot from two days ago bluetooth worked again. Maybe the recent update contains a bug?

I am running (“cat /etc/os-release”) Tumbleweed version 20210420 KDE and I am able to connect my BT headset but if I select it as Audio device no sound.

https://susepaste.org/images/96458307.png

After some waiting (two minutes?) however, the audio started automagically working again.

Which release are you running?

I did an extensive upgrade the other day. My current version of tumbleweed:

VERSION="20210420"

Now my bluetooth is working again. I’m not sure what the problem was but now bluetooth works seamlessly with my jabra ear buds. As soon as I take them out of their case they connect to my laptop and the sound output defaults to them. When I put them back in their case the sound automatically switches back to the laptop’s speakers.