Bluetooth (PulseAudio) issue with Audio speaker

Greetings,
New to the Linux space and OpenSuse. Not really good with computer but yet decided to move to Linux OpenSuse Tumbleweed because Win10 is not compatible with my old rig. Things are tight at the moment and can’t afford a new computer.
Everything seems to be working as expected but a Bluetooth speaker. I can connect but when I resume from sleep, I cannot reconnect back to PulseAudio as per log.
I went through massive amount of post on the internet. Found a lot of people with the same issue but with no resolve. Any help is much appreciated.

bluetoothd[1105]: profiles/audio/avdtp.c:cancel_request() Start: Connection timed out (110)

 pulseaudio[1882]: Transport Acquire() failed for transport /org/bluez/hci0/dev_F4_4E_FD_19_52_4D/sep1/fd0 (Input/output error

bluetoothd[1105]: profiles/audio/avdtp.c:cancel_request() Abort: Connection timed out (110)




I have made some progress. I am posting for visibility in case it can help others and for discussion. I am spending quite some time on this. Keep in mind that I am a complete noob. I will say stupid things and make a lot mistakes but willing to learn.
Step 1 - Fresh install of Tumbleweed KDE two days ago - First step with Linux and OpenSuse :wink:
Step 2 - Setting my workflow, I am trying to connect one single bluetooth speaker. Add bluetooth device (straight forward) and connect (pair and connect).
Step 3 - Machine goes to sleep. First issue. Cannot reconnect to pulseaudio (see first post for logs).
Step 4 - Reboot and reconnect to speaker. Second issue. High cpu usage with SMPlayer and VLC.
Step 5 - Disconnect speaker from bluetooth, Still high CPU usage through laptop computer due to sound and video…
Step 6 - Install VAAPI. High CPU from sound and video appears to be solved.

SIde note:
Yesterday, massive update through the pipes. I have no idea why (suspect Packman repo). Keep in mind that I installed the system 2 days ago. This morning run through the updates. My system became corrupted and unusable. Fresh install this morning… :stuck_out_tongue:

In conclusion, using VAAPI appeared to have solved the issue of high CPU from sound and video but NOT the original issue which is the connection through bluetooth…
Why VAAPI helped. I cannot say… But I am glad as I have a tiny laptop and resources are expensive in my space…

I am a bit scared that updates will come through again and corrupt my system… I had to use Packman repo for the h264 plugin…

Last side note:
I use h264ify plugin for Firefox. If you do not install H264, youtube videos won’t be playing…

Any input is much appreciated. :shame:

TW is a rolling release you get almost a new OS ever week or so ergo very large updates often

Note you did not say what hardware or what desktop???.

E7440 Dell. First gen
Indeed rolling release it is. The irony is, I did my second fresh install with the same usb key I used for my first fresh install.
I did enable the Packman repo again and out of curiosity looked for any updates referring back to the last botched updates where I had huge amount of updates following the exact the same fresh KDE install. I get nothing… My system says “up to date”…
I cannot comprehend for the life of me what is happening…
In any case, its working well at the moment without any issue besides the initial problem and until the next batch of updates ( stressfulll) rotfl!

If my system breaks again I will go for ‘leap’ this time. I think tumbleweed is more for the aficionados…

I am still having the initial issue with the speaker I have.
Impossible to reconnect to pulseaudio after resume from sleep.
Its been 2 days. I guess its too long without a resolve. I need to be able to use that little speaker and not have to worry about re-connection all the time. Will check if the grass is not greener on the other side lol!

It’s always worth to check. This is a very common problem however. Hardware does a lot of things during sleep/resume and often something brakes and it’s usually difficult to troubleshoot (at least for me). For example on surface pro tablet in Windows 10 my sound stops working completely after sleep/resume. Logging in and out fixes the problem.

For your problem restarting pulseaudio might be a workaround (don’t know if this is viable for you). Do let us know if it works better with Leap :slight_smile:

The procedure probably is similar to a bluetooth head set.
Please see this link:
https://wiki.archlinux.org/index.php/bluetooth_headset
When you are in that link you will see the package needed for bluetooth for Arch
Take note that in opensuse this packages are not exactly the same as Arch but probably you will be able to determine
it in yast2. You need also to install the

bluez-auto-enable-devices

Next follow the steps in the link above and you will be good to go.

Hopefully it will work for you as this one worked with my bluetooth iQ Podz headset