Bluetooth peripherals on OS11; logitech keyboard, mouse

… actually, the mouse is working, don’t really know how, I just kept trying and pressing buttons in different sequences until it started working.

The keyboard however does not work. It worked with OS10.3 (KDE) and Ubuntu 8.04 (GNOME).

The Keyboard is actually picked up and displayed with the mouse, but only when I press a key on it, but it does nothing and disconnects within seconds. I managed to catch it and add it to the trusted devices, so now when a press a key the little connector icon displays for about 2-3 seconds.

The keyboard, together with the mouse, is the Logitech MX5000 Bluetooth kb/mouse set.

  • istvanv,

batteries in the keyboard are okay? It sounds like empty batteries to me.


The keyboard has an LCD screen which displays an icon if the battery is getting weak, plus it has been changed not that long ago, so I’m sure that’s not it.

I am having the same problem with suse 11 and my microsoft bluetooth keyboard, it connects for 1-2 seconds, then disconnects. any keypresses connect it, but it soon disconnects.

any solutions would be appreciated.

funny thing is it worked fine with 10.3 and it works flawlessly in windows, so the batteries can’t be dead.

  • big red and all,

you did pair the devices, right?


Yes. I have used this keyboard (and mouse) under 10.3 and during my brief test-run of Ubuntu 8.04 and I am using the mouse without any problems right now.

Both the keyboard and mouse are listed in the “Bonded devices” - ad set as trusted - list in the Bluetooth Preferences window, both have a yellow star icon, but only the has the connector icon, while the keyboard’s flashes up for a second or two after attempting to connect it.

The mouse and keyboard are recognised as “Logitech MX1000 mouse”
and “Logitech MX5000 Keyboard” respectively.

I’ve also tried all “Mode of operation” settings.

Hello everybody,

I’ ve the same problems like istvanv with a microsoft bluetooth mouse and keyboard combination. The mouse works fine, but if I press any key on the keyboard no sign appears on the screen.

The keyboard and the system are paired. Under 10.3 everything worked fine. I also tried out different version of 11.0 (32-bit and 64-bit) on different PCs.

That must be a global problem of 11.0. Who will care about it or whom do we have to tell this problem for a solution?

Every suggestion are highly welcome

kind regards


Sorry to add a “me too” to the thread, but… me too!

I have a Logitech PS3 bluetooth keyboard which worked perfectly under 10.3, but behaves exactly as described above under 11.0.

The only slight difference for me is that this keyboard has a built-in touchpad, which was recognised as a mouse under 10.3, but now behaves the same as the keyboard when you try to use it, i.e. it connects, nothing happens, and it disconnets.

> I have a Logitech PS3 bluetooth keyboard which worked perfectly under
> 10.3, but behaves exactly as described above under 11.0.

since two (at least) have the same problem, maybe there is a bug…

perhaps you two should collaborate on submitting it…or, (of course)
first research to see if one already exists…

in either case it would be nice to following logitech bluetooth users to
know–so come back to this thread and update it after you have sent the
bug report or learned that one is already in the works…

DenverD (Linux Counter 282315)
A Texan in Denmark

Hey just wanted to let you know that Im suffering from the same problem with my microsoft bluetooth keyboard.

Ive managed to pair the mouse no problem, I can see it as a paired device with a little gold star next to it. As for the keyboard well its a different matter. When I press the pair button KBlueMon picks up the keyboard. So I go into KInputWizard and do a search to pick it up!. I click setup and as it pairs it asks for a code to be entered so I out in a 4 digit number for example: 1234. The keyboard connects but then when I press a key it connects then disconnects. I have tried without putting a code in and it does the same.

From the command line I can issue a

> hciconfig
> hcitool inq
> hcitool scan
> hcitool info xx:xx:xx:xx:xx
> hcitool cc xx:xx:xx:xx:xx (note this connects then disconnects)

Its obvious its to do with the authentication of the device. the mouse does not need any secure pairing however the keyboard does. Is there a config change to the hcid.conf file to be made??? Otherwise I would agree this looks like a bug!

I have the same issue with the logitech combo mouse MX1000, that works, and with the keyboard MX5000 get no connection.

Did anyone already raised the bug?

In the meantime I learned a little bit more about this problem. I think not that the problem is a specific opensuse 11.0 problem. It looks like the problem is KDE4 related. When I use OpenSuse with KDE3 instead of KDE4 the whole bundle (mouse MX1000 and keyboard MX5000) is working.

Under KDE3 ‘bluez’ is as adapter running. I didn’t have the impression KDE4 is using ‘bluez’ too.

Very interesting. After first running OpenSuse with KDE3 I restarted with again with KDE3. Then I was asked to connect to the mouse and keyboard permanently, I accepted it.

Now the mouse and keyboard are even working under KDE4.1!!
I see also the blue bluetooth icon the systemtray (running with ‘bluez’).

I suppose in KDE4 is something missing to build up the correctly connection.

I’m having much the same problem, but I’m not using KDE4. I chose KDE3 when installing OS11.0 (32-bit). Bluetooth keyboards just don’t want to work.

I have the Logitech diNovo media desktop laser package (Logitech Mx 1000 Laser Mouse, diNovo bluetooth keyboard, and media pad.)

The Logitech USB/bluetooth dongle isn’t recognized. When plugged in all the items on the popup menu for the bluetooth tool are ghosted. I also have a Kensington USB/bluetooth interface that is recognized just fine, so that’s what I’m using.

After many repeated attempts at connecting, and reconnecting, and a reboot, the Logitech Mx 1000 Laser Mouse is finally recognized and works consistently.

While the bluetooth setup for the keyboard goes through all the steps of connecting, pin entry, and permitting automatic authorization, no typing on the keyboard accomplishes anything. It is listed as a trusted device and when keys are pressed on the keyboard the star appears next to the device in the dialog, but no characters will appear anyplace that accepts keyboard entry.

I have exactly the same problem with the Apple bluetooth keyboard. It goes through the motions of being connected, etc., but never provides input.

(I haven’t tried to set up the Media Pad.)

I also tested with my Precision M90 laptop that has bluetooth built in (running OS11.0 64-bit). The Logitech mx 1000 mouse, and a Kensington slimblade trackball both setup and work fine. However, like with the other computer, the bluetooth keyboard setup goes through the motions, but I get no input from the diNovo or the Apple bluetooth keyboards.