Bluetooth on 8265 Intel Wireless Duo not detected

I’m reverting back to OpenSuse tumbleweed after spending some time with another distribution.

Problem: fresh installation with latest kernel from repo doesn’t recognize Bluetooth on

 04:00.0 Network controller: Intel Corporation Wireless 8265 / 8275 (rev 78)

related dmesg indicates nothing (to me):

rfkill list only shows:

0: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no

hciconfig returns empty list.

Any suggestions on course of action?

Okay, after a little discussion on the IRC I’ve got it fixed. It was a really strange fix, though. Suggestion on IRC was to reinstall the wifi/bt card, so disassembling the laptop. I’ve figured I should try to look if it works on another LiveUSB; booted into Fedora 27 live (which failed to start properly), rebooted back to OpenSUSE only to see that now my BT works.

My thoughts on that from google and from what I know about that kind of hardware are that probably card was switched to some wifi-only mode or something in the lines; there are no Fn/F* combinations that allow switch of anything network-related though, so I’m not sure on

a) how it happened

b) how to fix it if it happens again (because booting into liveusb for such thing is just… weird)

If there is any input on how to possibly switch mode of intel wireless hardware, please do so.
Initial problem is fixed for now, though.

Thanks a lot. I have an intel 8260 and it worked for me. Well, I couldn’t remove the wifi/bt card because it seems integrated to motherboard But I removed the wires (and I put them again obviously). I did the same with bios battery (remove it and put it again), so I can’t be sure which action worked, but my Bluetooth is working now. How long it will work? We’ll see.

Sounds plausible until you try it. It doesn’t look like impossible conditions.