Bluetooth mouse connection not working as expected in OpenSuse 11.3/KDE 4

I have installed OpenSuse 11.3 on my laptop. My configuration includes a usb dongle to which I connect a Microsoft Bluetooth Notebook Mouse 5000. Under OpenSuse 11.3 the mouse pointer is** not activated** properly after boot/login.

To force the Device Manager to accept the mouse properly, I always have to open Kbluetooth Device Manager, ‘remove’ the mouse (which is always listed in the Device Manager list). (Just ‘connecting’ the mouse in the Device Manager never works). I then have to switch off the mouse power, and proceed to ‘add’ the mouse again to the Device Manager using the wizard to set it up (i.e switch on mouse power on, make the device ‘discoverable’, wait sometimes quite a long time for the device to appear in the list etc, finally making the ‘connection’ in the Device Manager. This seems to be the only way to get a successful result.

I had a configuration under OpenSuse 11.2/ KDE4 where the mouse pointer was already working as expected during the boot/login procedure. What has changed in OS 11.3/KDE4

Can anyone help find a solution?

  • hnimmo,

when the mouse connects, do you set it to “Always trust”?
My BT mouse works flawlessly here, so I assume it is something in your setup. Note that KBluetooth might take a minute after login until it discovers and connects to the mouse.


…always! I do not know how often I have been asked and my answer is always ‘always trust’. I am not sure I have waited for as long as a minute…a minute is a rather long time; and with 11.2 it was a matter of a few seconds after starting to move the mouse about that the pointer came alive.

By the way, I have to go through the same procedure every time I switch the mouse power off.

Thanks for the tip though…I will try to be patient next time

…I think I can safely say, even after 2 minutes the mouse is not connected. And if I try to connect it using the Device Manager, the status switches to ‘connected’ at first and then back to ‘disconnected’ after a few seconds. The only remedy is to ‘remove’ it from the device manager list and ‘add’ it again, as I described above.

Please create a new user on your system and configure the mouse for that user.
Same behavior?
Else it may be the fix, since the mouse configuration is systemwide, not per user.


The behaviour is exactly the same with the new user

what backend are u using? Bluez? you could try using bluedevil…

I am using whatever OS11.3/KDE4 installation employs as standard. (I think it is bluez)

  • hnimmo wrote, On 08/03/2010 11:06 AM:
    > I am using whatever OS11.3/KDE4 installation employs as standard. (I
    > think it is bluez)
    I realized I have a similar problem with my BT mouse when I have the KDE desktop effects enabled. So if that’s the case on your system, try and disable desktop effects.


I cannot disable Desktop effects, the tick box is ‘greyed’ out!

  • hnimmo wrote, On 08/07/2010 12:06 AM:
    > I cannot disable Desktop effects, the tick box is ‘greyed’ out!

… which means they aren’t enbaled. Back to the drawing board.


No,no…they are enabled. The box is ‘ticked’ but ‘greyed’ out so that they cannot be disabled.

I have the same issue. In opensuse 11.2 the mouse worked fine on my laptop. In 11.3, disconnects immediately.

This has been happening to me as well. As soon as I started KBluetooth and activated my mouse, the dialog to add a new device pops up. I click “Always Trust” every time, yet it would still pop up. I went into the configuration and set bluetooth as “discoverable”, and the dialog stopped popping up, but when I went to the BT Device Manager, the mouse wouldn’t stay connected. It just kept disconnecting when I’d press a button or otherwise use it. Also, so far, it has never worked, I’ve never been able to move the cursor with the BT mouse.

Hope this gets fixed in the new OpenSUSE.

Seems on KDE that blueman is the thing to use. Else open a konsole
session and run the command;

hcitool scan

Now, before running the above command, power off the
mouse and press the connect button.

I use Gnome and have to run that command multiple times (eg ~20)
before I see the device and MAC address appear, once I see it in the
terminal windows, then i run the GUI config tool and it connects fine
after reboots etc.

Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel
up 4 days 8:12, 3 users, load average: 0.09, 0.07, 0.01
GPU GeForce 8600 GTS Silent - Driver Version: 260.19.26

Thank you, this worked!