Bluetooth keeps failing with openSUSE 13.1

I cannot get bluetooth to work, it keeps crashing. I’m attempting to connect to a motorola bluetooth headset (this laptop was able to connect to it when I had opensuse 12.3 on it). It was able to find the headset and pair it but keeps crashing:

 Executable: bluedevil-audio PID: 1794 Signal: Segmentation fault (11) Time: 02/25/14 06:35:20 PM


Clicking “restart application” simply crashes again and shows the same alert.

openSUSE 13.1
KDE 4.11.5
Samsung Series 9 NP900x4C (UEFI/Secure Boot turned off)

And after pairing with the Motorla device it will pop up a notification that the connection timed out. (NOTE: This same headset worked with this same laptop with a previous version of openSUSE)

You could try to update to bluedevil 2.0~rc1 from the KDE:Extra repo, that one works better.

sudo zypper ar http://download.opensuse.org/repositories/KDE:/Extra/openSUSE_13.1/ KDE:Extra
sudo zypper in bluedevil-2.0~rc1 libbluedevil2-2.0~rc1

(if you already have KDE:Extra on your system, just omit the first line of course)

I don’t use Bluetooth myself though.

Thank you, this almost fixes it!

  1. I can connect and it doesn’t crash

  2. But audio (flash in the browser) is still playing via the laptop speakers

How do I fix that?

This seems only temporary, but I fixed it by going into “System Settings”->“Multimedia”->“Audio and Video Settings” and choosing to “prefer” the bluetooth headset. But won’t this need to be reset every time I restart and reconnect the headset? And why did I even need to do this?

Pulseaudio Volume Control may be a a bit easier to use. pavucontrol package

It allows switching the source and out put streams to audio devices