Bluetooth in KDE in 13.1 64

I have tried every suggestion I can find to get my Logitech bluetooth mouse to work. It worked fine in 12.3, but since the upgrade, nada.

It is registered but I get a “no supported services found” if I click on the icon on the task bar. It says it is connected and paired, but doesn’t work.

I have tried downgrading to bluez4, but still no success.

Any ideas on when support for bluez5 on KDE is forthcoming?

I am running into the same issue. I’ve tried a HP K4000 keyboard and a Razer Orochi mouse, I also tried trying another repo that had a newer version of bluez but that had acted the same. I was able to get my mouse to work by using a manual pin of 0000 to connect it and turning the bluetooth off and on to get it to see the mouse to work. I am unable to get the keyboard to work because it generates a dynamic pin that must be entered for it to work but all I get on the screen is a spinner and the number never shows. btw this never happened on 12.3.

I ran a tail -f command on /var/log/messages to see what was happening when I attempted to pair the keyboard and this is what comes up on both the Offical release from openSUSE (5.8) and the other repo with 5.12

2013-12-17T20:25:48.167805-08:00 TheNinja dbus[557]: [system] Rejected send message, 3 matched rules; type="error", sender=":1.55" (uid=1000 pid=1739 comm="/usr/bin/bluedevil-wizard ") interface="(unset)" member="(unset)" error name="org.freedesktop.DBus.Error.UnknownMethod" requested_reply="0" destination=":1.50" (uid=0 pid=1690 comm="/usr/lib/bluetooth/bluetoothd ")

this is my bluetooth

Bus 001 Device 003: ID 0cf3:3005 Atheros Communications, Inc. AR3011 Bluetooth

here is my lsmod to show what modules are loaded

Module                  Size  Used by
hidp                   27812  1 
fuse                   95850  2 
rfcomm                 73157  12 
af_packet              39774  6 
xt_tcpudp              12884  2 
xt_pkttype             12504  3 
xt_LOG                 17718  10 
xt_limit               12711  10 
ip6t_REJECT            12939  3 
nf_conntrack_ipv6      18938  3 
nf_defrag_ipv6         34645  1 nf_conntrack_ipv6
ip6table_raw           12683  1 
ipt_REJECT             12541  3 
iptable_raw            12678  1 
xt_CT                  12956  4 
iptable_filter         12810  1 
ip6table_mangle        12700  0 
nf_conntrack_netbios_ns    12665  0 
nf_conntrack_broadcast    12589  1 nf_conntrack_netbios_ns
nf_conntrack_ipv4      15012  3 
nf_defrag_ipv4         12729  1 nf_conntrack_ipv4
ip_tables              27239  2 iptable_raw,iptable_filter
xt_conntrack           12760  6 
nf_conntrack          105228  6 nf_conntrack_ipv6,xt_CT,nf_conntrack_netbios_ns,nf_conntrack_broadcast,nf_conntrack_ipv4,xt_conntrack
ip6table_filter        12815  1 
ip6_tables             27025  3 ip6table_raw,ip6table_mangle,ip6table_filter
x_tables               34059  15 xt_tcpudp,xt_pkttype,xt_LOG,xt_limit,ip6t_REJECT,ip6table_raw,ipt_REJECT,iptable_raw,xt_CT,iptable_filter,ip6table_mangle,ip_tables,xt_conntrack,ip6table_filter,ip6_tables
bnep                   19704  2 
arc4                   12608  2 
snd_hda_codec_hdmi     45213  1 
snd_hda_codec_realtek    51700  1 
rtsx_pci_ms            18151  0 
rtsx_pci_sdmmc         23482  0 
memstick               16760  1 rtsx_pci_ms
mmc_core              124734  1 rtsx_pci_sdmmc                                                                                                                          
iTCO_wdt               13480  0                                                                                                                                         
iTCO_vendor_support    13718  1 iTCO_wdt                                                                                                                                
snd_hda_intel          48171  2                                                                                                                                         
snd_hda_codec         205080  3 snd_hda_codec_hdmi,snd_hda_codec_realtek,snd_hda_intel
snd_hwdep              13602  1 snd_hda_codec
snd_pcm               110211  3 snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec
x86_pkg_temp_thermal    14162  0 
coretemp               13435  0 
kvm_intel             142707  0 
kvm                   469295  1 kvm_intel
crc32_pclmul           13113  0 
crc32c_intel           22079  0 
snd_seq                69752  0 
ghash_clmulni_intel    13259  0 
cryptd                 16262  1 ghash_clmulni_intel
snd_timer              29423  2 snd_pcm,snd_seq
snd_seq_device         14497  1 snd_seq
serio_raw              13413  0 
pcspkr                 12718  0 
snd                    87417  13 snd_hda_codec_hdmi,snd_hda_codec_realtek,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm,snd_seq,snd_timer,snd_seq_device
btusb                  32266  0 
rtl8188ee             138179  0 
bluetooth             396742  37 hidp,rfcomm,bnep,btusb
rtl_pci                35543  1 rtl8188ee
rtlwifi                90192  2 rtl8188ee,rtl_pci
mac80211              635562  3 rtl8188ee,rtl_pci,rtlwifi
r8169                  71677  0 
mii                    13934  1 r8169
cfg80211              522716  2 rtlwifi,mac80211
rfkill                 26487  4 bluetooth,cfg80211
rtsx_pci               40225  2 rtsx_pci_ms,rtsx_pci_sdmmc
i2c_i801               22444  0 
lpc_ich                21080  0 
mfd_core               13435  2 rtsx_pci,lpc_ich
shpchp                 32936  0 
mperf                  12667  0 
soundcore              15047  1 snd
snd_page_alloc         18710  2 snd_hda_intel,snd_pcm
sg                     40629  0 
dm_mod                 92428  0 
autofs4                42770  2 
thermal                18754  0 
processor              44625  0 
i915                  710199  3 
drm_kms_helper         52710  1 i915
xhci_hcd              108655  0 
drm                   313440  4 i915,drm_kms_helper
i2c_algo_bit           13413  1 i915
button                 13952  1 i915
video                  19507  1 i915
thermal_sys            36646  4 x86_pkg_temp_thermal,thermal,processor,video
scsi_dh_rdac           17447  0 
scsi_dh_emc            17258  0 
scsi_dh_alua           17295  0 
scsi_dh_hp_sw          12895  0 
scsi_dh                14882  4 scsi_dh_rdac,scsi_dh_emc,scsi_dh_alua,scsi_dh_hp_sw

please let me know if there was any more info to provide for this issue

I decided to change my approach to the problem. Office Max had a sale on a Logitech wireless keyboard and mouse reduced to $19.99, so I bought it. Out with bluetooth and in with usb wireless. It works great, and I wanted a different keyboard anyway. I’ll use the bluetooth mouse with my MacBook Pro.

I’m sure 13.1 will get the problem fixed soon, but the old MS mouse with a ball I hooked up in the interim was driving my wife crazy, so I just went the quick and easy route.

Seems to me that bluedevil 5 is well broken none of the distro’s want to talk about it and as far as I can see little work is being done on resolving the issues.

I tried couple of weeks ago to link a bluetooth headset. I had to use the CLI to pair the device because some of case conversion between the detection and pairing in the code making it impossible for one side to recognize the device ID from the other. After that trying to connect it with bluedevil got a crash. So yes, well broken it is.

I got bluetooth to work by installing suse-13.1-gnome and then adding the kde desktop afterward by using yast2, now my bluetooth headphones work flawlessly.
I’m not sure why it works though perhaps there has been an update to correct it for all I know. I’m not an expert on this and have been stumbling around for weeks trying to get it to work.
SUSE 13.1 has been really annoying on this and other issues.

Thank you!! doing this finally got my Logitech Mouse to work! actually I still had to select Connect from the Known Devices, but after that I can now use my T630

hmmm, after a day of use it seems like the connection is actually very glitchy. from the moment I initialize the connection, I get a segmentaiton fault error, every time

Application: Bluetooth Input Helper (bluedevil-input), signal: Segmentation fault

 Using host libthread_db library "/lib64/".
 [KCrash Handler]
 #5  0x00007f455219168b in BlueDevil::Device::UUIDs() () from /usr/lib64/

 #6  0x0000000000404621 in _start ()

and about half the time the mouse becomes pretty unusable. scrolling doesn’t work, right click behaves like left click, etc.

Are you using KDE 4.11.x or KDE 4.12.x Repos?

I am using KDE 4.11.x with The KDE updates/additional software repo:

When I pair a Bluetooth device though KCM-Bluetooth I receive a Knotify message asking me to confirm the generated pin.

I moved to the BlueTooth packages in this repo as they are newer and their are more than what is provided from the standard repo.

I have not tested BlueTooth with the KDE 4.12.x repos yet.

My bluetooth headphones would not connect until I installed bluedevil 2.0~rc1-16.5 from the KDE Extra repository at the link in the quote. All the other bluetoooth packages on my systems (13.1 KDE 4.11.5 , both 32-bit and 64-bit) are from the Main or Update repositories.

To get the headphones to work, I had to remove them from the bluetooth configuration and add (pair) them again. After removing and adding, the headphones work.