bluetooth: How to "pair" and exchange VCards with phone ?


I have a Gigaset SL 78 H Handset, which supports Bluetooth and supports exchange of phone book entries via VCards.
On the other side, there is my PC, running Suse 11.2 (64 Bit) (patched up to date), KDE 4.3.5 and - thanks to the forum - a working bluetooth USB dongle.

I have the KDE KBluetooth4 running - Bluetooth Icon in the system try. (find the list of installed blue…-packages below)
Unfortunately I can’t get the version via Right-click/About
This simply seems to do nothing (one of the absurdities)
In the SW package list in yast2 I find kdebluetooth4 which is version 0.3-9.1.

Now my understanding is, that I first have to “pair” the two devices.
On the computer I start KBluetooth4/[Right Click]/Device Manager
There I click [New]
At the same time at the phone, I start searching for a data device.
Soon after this, the phone reports a found device, named as the one I find in KBluetooth4/[Right Click]/Settings/Bluetooth Adapters.
[BTW - next absurdity: If I change the name here, this gets stored; but if I change the discoverable timeout, this isn’t stored and always goes back to “none”]

The “Bluetooth Device Wizard” also reports a device, named as the bluetooth name of my phone.
(I changed both the bluetooth names of my PC and the phone from the defaults - so I’m sure, they are really mine)

I then select my phone in the “Bluetooth Device Wizard” and click “Next”.
At the phone I ask it to “trust” the found device.

The results are:
The phone asks me for a pin - which I don’t know.
The “Bluetooth Device Wizard” on the PC ends with “Sorry, your Bluetooth Device does not support input service”

And now I’m stuck…

But somehow it even gets better:
Once - but just once - on the PC I got asked to enter a pin; when I entered this at the phone, I got the pairing done. But I have no clue, why this worked at that time.
After that I could send a vcard from the phone to the PC. The application told me, that it received data - but I couldn’t find, where it was put (I pasted the clipboard input - but it contained old text and did a ‘find ~ -mtime -1’ and tried to find something plausibly looking - but failed)
Trying to send a vcard from the clipboard to the phone failed.
Then I lost the pairing again, when I played around with devices.


  • How do I do the pairing ? In a repeatable manner… :slight_smile:
  • Should I use other SW (in addition ?) What ? What versions ?
  • How do I exchange the vcards ?

All help and pointers welcome !
(And yes, I tried to google for this and searched the forum; unfortunately many of the google results seemed to apply to other SW (versions) and talked about configuration files, which simply don’t exist on my PC)

Regards and TIA


Here is the list of the installed (relevant ?) packages:

> rpm -qa | grep -i blue