Bluetooth Headset on opensuse 11.1, again.

Did anyone successfully get bluetooth headset work on opensuse 11.1? My Jabra BT 125 can be recognized but can not be connected. I created ~/.asoundrc as the instruction I found from Bluz but it’s still not working. I can not find anything about my headset from PlusAudio manager.

Any help? Tack!:\

nope :-s. also tried btsco… doesn’t compile :frowning:

okay … i have some sound: i used the bluez3 packages instead of the standard bluez. used the kde 3.5 bluetooth applet to pair the device. next i followed the following instructions: Bluetooth Audio with PulseAudio - FedoraForum.org

after that you need to redirect the audio stream through the pulseaudio volume control window.

only …my audio is jumpy, not really useable, lemme know if you get yours to work, and how :slight_smile:

its working a little better now, except i don’t know why. the only difference i have noticed is that the first time i started pulseaudio from the terminal it said:

                                                                                                                        
itchy8me@superlux:~> pulseaudio                                                                                                             
W: main.c: High-priority scheduling enabled in configuration but not allowed by policy.                                                     
W: core-util.c: setpriority(): Permission denied
W: ltdl-bind-now.c: Failed to find original dlopen loader.
W: pid.c: Stale PID file, overwriting.
N: module-alsa-sink.c: Increasing wakeup watermark to 40.00 ms

that was the first time i started pulse

the second time gave:



itchy8me@superlux:~> pulseaudio
W: main.c: High-priority scheduling enabled in configuration but not allowed by policy.
W: core-util.c: setpriority(): Permission denied
W: ltdl-bind-now.c: Failed to find original dlopen loader.
N: module-alsa-sink.c: Increasing wakeup watermark to 40.00 ms
N: module-alsa-sink.c: Increasing wakeup watermark to 80.00 ms

im guessing that the wakeupo watermark had something to do with the jumping/skipping audio, it still not perfect though, have skips every 5 seconds or so now. Is the wakeup watermark setable?

info on the skipping sound stream:

https://tango.0pointer.de/pipermail/pulseaudio-discuss/2009-January/002932.html

I updated the audio troubleshooting guide to cover some cases of “jump” / "skipping sound " (which was pulse audio related). … Not sure if this is part of your problem, but you could try the fix: SDB:AudioTroubleshooting - a fix for choppy / skipping sound- openSUSE

Hi, I just posted How-to use a bluetooth headset with SuSE 11.1 - openSUSE, my headset works without problems.
Just wanna say thanks a lot to oldcpu for your posting on audio issues, great work.

Great timing, my Jabra headset was getting dusty :wink:

Cool, Thank you blondebuilder. :smiley:

Hey blondebuilder, … if you don’t mind, I’ll link to your “how-to” for bluetooth headset from the “openSUSE audio troubleshooting guide”.

Hi oldcpu,
sure, please do that.

I started with Suse 11.0, but I did not manage to compile the btsco package advised by the howto at Bluetooth headset with openSUSE 11.0 « Tuxbox Blog, so I upgraded to 11.1 hoping that it will work automatically as described by blondebuilder above. Unfortunately, the answer is no. My headset BTS-9000 can be used to listen to music if one follows the steps of the mentioned howto, but in skype I cannot get it working.

google tells me that it is an international problem:D, German, Italian, Portugese amateur linux users all wonder how to overcome the error message when compiling btsco:

>./configure
line 10762: XIPH_PATH_AO: command not found

with the newest libao and libao-devel packages already installed. We are waiting for the saviour or the dear developers to automatize the process:)