Bluetooth Headset/Headphones Only Sound Out Device but Not Sound Input

Hi

Im using OpenSuse 13.2 x64bit with the below hardware:

Jabra BT4010
Philips SHB7500

and I have/tried the two following bluetooth modules: v2.1 (chipset: dont know) v4.0 (with chipset BCM20702A0)

both adapters via Gnome Bluetooth Panel and Sound menu - Pairs with the SHB7500 headphones correctly but Only sees it with A2D Profile ( no other profile is selectable) and only see it as Output device
and not also as Input device ( with the built in Microphone) - Under other OSes SHB7500 Pairs and can be used with the built in Mic to make Skype calls, etc. and listen to music

I tried pairing also the older jabra BT4010 it Pairs successfully and connects up with both Bluetooth adapters for a second and then disconnects ( cant make it work)

Im stucked with my Webcams Logitech C270’s builtin Microphone which shows up as input device and works perfectly

Any ideas?

I tried removing and pairing the Headphones in Headset / Handsfree / Audio Sink modes but none made any difference…Only as Output not as Input device in Gnome / Sound / Input devices

bump

Same issue here with v4.0 bt dongle and sennheiser momentum 2 wireless.