Bluetooth headset could not choose High Fidelity Playback (A2DP)


I’ve got an LG bluetooth headset. Pairing and connection works well, but the thing is that it is hard to turn on Stereo mode. In the sound preferences, after connection, I can always choose Telephony Duplex and the headset starts receiving sound. But when I try to choose High Fidelity Playback (A2DP), respond. In other words, even if I choose High Fidelity Playback (A2DP) (it is there at the Profile drop down menu), the status message stays on at Telephony Duplex.

Usually after a couple of disconnection - reconnection I could choose High Fidelity Playback (A2DP). But it is very inconvenient. I was wondering if this can be resolved.

Thank you,

I’m happy to report after I switched to tumbleweed and updated stuff, my laptop is correctly connect to the headphone with stereo setting. I guess pulseaudio-module-bluetooth update did the trick but I am not 100% sure, as I updated bunch of packages altogether.