Bluetooth headphone disconnecting WiFi when joining/create Google Meet

Laptop: Acer Extensa 15
Distros: Pop OS, Opne Suse TW
Headphone: Realme Buds Wireless 3
(On Ubuntu even the headphone mic is not recognized)

The same Bluetooth headphone works fine on Windows (dual boot)

System Info :
System Log:

Bluetooth and WiFi use the same 2.4 Ghz when not configured otherwise.

Try moving you WiFi to the 5 Ghz ( or 6 GHz) band and all your problems will be gone while also having a more stable/capable WiFi connection.

my router doesn’t have 5Ghz support, unfortunately, but the same headphones on the same laptop on the same wifi works fine for Google Meet.

If the 2.4Ghz band is the issue, how it work fine until I create/join google meet?

Simple, video/auto uses much more data then idle operation or a keyboard/mouse, when you start a Conference both WiFi data and Bluetooth audio start pumping way more data.

If you are on KDE, start System → System Monitor and go the History tab, the lowest graph is het Network data traffic, I do not know immediately to visualize Bluetooth usage.

Either making the headphone or the Internet connection wired will also solve the problem.

thnx for the reply. I’m sure that some fix must be there. But this is specific to Linux only. I’ve tried Ubuntu, PoP Os, Fedora, Opensuse TW.

I’m on KDE

I really want to use Bluetooth headphones. Bcuzz it has ANC. It’s very helpful in attending meetings

Okay, let me give you some pointers.

Bluetooth and Wifi can working “nicely” together if things are arranged nicely. Both WiFi and Bluetooth have interference mitigation functionality but for optimal coexistence the WLAN needs to “talk” with the Bluetooth “directly”. That works best with a combi BT/WiFi card from a vendor that took the effort to make this work. If Windows work, it might be that you have a such a combo driver with the correct BT+Wifi firmware, if things do no work for the same setup I would first make sure the same BT+Wifi firmware under Linux is used.

Without such a combi card still things can be made to work but all depends on particularities on how antenna’s are lined up and that is something that is not really under control.

I am sure going wired or going to 5G (a separate WiFi acces point is cheap) is the easier solution.

1 Like

How to do it ?

What did you find searching the Internet or using ChatGPT or something like it?

I never did do it myself, might be good to start a separate thread on it based on what you found already out.

I found out that this WIFI card issue. Bluetooth co-existence is the problem.

Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter

Their docs says this card does that. This worked fine on 5ghz. I tested it on another router. I found something on Arch docs. It gave some command to disable it. But when i run it i get:

# /etc/modprobe.d/iwlwifi.conf 
# iwlwifi will dyamically load either iwldvm or iwlmvm depending on the 
# microcode file installed on the system. When removing iwlwifi, first 
# remove the iwl?vm module and then iwlwifi.

remove iwlwifi \\ (/sbin/lsmod | grep -o -e \^iwlmvm -e \^iwldvm -e \^iwlwifi | xargs /sbin/ rmmod) \\ && /sbin/modprobe -r mac80211

Finally this is Linux issue. Bcuzz same 2.4 ghz works with same headphone on windows dual boot

Nice you found out yourself this is a Bluetooth co-existence issue.

Not sure if I call this a Linux issue however, I did work on BT-coexistence and as far as I know Linux nor a Linux driver does do any coexistence, that is all card functionality in the card firmware/hardware.

I wonder: Any idea what will be your next step?

does that mean I’ve to install explicitly the linux drivers for that card for co-existence ?

I ran lspci -k and lsmod. got this, is it relaying any info?

If you read my my earlier replies in this thread you will find what I think is what I should do and let me tell you, it is not the Linux driver.