Bluetooth enables itself automatically

Hi everyone,

I’m on OpenSUSE Tumbleweed with Gnome desktop environment, and there’s one small issue that keeps bugging me. Everytime I start my computer, Bluetooth is on. I don’t use it that often so I turn if off, but everytime it toggles itself back on.
I would expect it to behave similar to other distributions where toggling this setting from the top-right settings menu leaves things as they were last you changed them.

I’ve looked inside Yast > Services Manager and found an entry for Bluetooth to start “On Boot”. But this disables Bluetooth entirely, so when I need it I have to come in here and enabled it back on again. Is there any other settings that I can check to make sure this menu behaves correctly?

To be clear I’m talking about this setting:


Thank you!

Confirming the same behaviour here.
Bluetooth has been somewhat erratic on this laptop in the past, so I didn’t notice.
I’ll let you know if I find something useful.

“Airplane mode”, or disabling all radios, also has the same behaviour.
Apparently “soft blocking” radios does not survive a reboot.
It looks independent of Gnome, try the “bluetooth” or “rfkill” commands, nothing changes here.

It might be related to bluez-auto-enable-devices:

LT-B:~ # zypper info bluez-auto-enable-devices
Loading repository data...
Reading installed packages...

Information for package bluez-auto-enable-devices:
Repository     : Main Repository (OSS)
Name           : bluez-auto-enable-devices
Version        : 5.66-1.4
Arch           : noarch
Vendor         : openSUSE
Installed Size : 10.9 KiB
Installed      : Yes (automatically)
Status         : up-to-date
Source package : bluez-5.66-1.4.src
Upstream URL   :
Summary        : Configuration that automatically enables all bluetooth devices
Description    : 
    Contains configuration that automatically enables all bluetooth devices
    that are connected to the system if no other tool is handling them (e.g.
    desktop specific applets like blueman or GNOME or KDE applets).

LT-B:~ #

Bug 1198906 might also be interesting.
BTW I checked with LEAP 15.4: disabling bluetooth survives reboot, but then I couldn’t enable BT again and Bug 1201815 – Inconsistent Bluetooth status display showed up again, so the current behaviour in TW is a step forward in my view.

Hi, not seeing the issue here on MicroOS (20230301) with GNOME DE on a Dell Venue Tablet, wifi on or off, bluetooth stays disabled…

You may try to edit file /etc/bluetooth/main.conf changing the last line of the following section

# AutoEnable defines option to enable all controllers when they are found.
# This includes adapters present on start as well as adapters that are plugged
# in later on. Defaults to 'true'.
# AutoEnable=true



and see if it works for you.
BTW it just brings Bug 1201815 – Inconsistent Bluetooth status display to new life on my HW, so I will stick with the default settings.

1 Like

Thank you very much for all the detailed answers! I will try to toggle this and check again tomorrow and see if things work out correctly.

Hi, this seems to have worked fine. I just turned on my computer and Bluetooth is disabled, as expected, but I can still toggle it back on from the menu.

About that bug, I was using OpenSUSE Leap 15.4 until a couple of weeks ago and I didn’t have this issue there. Or maybe I assumed it didn’t because the toggle worked (I didn’t actually connected to Bluetooth then as I don’t use it too often).

Thanks for the feedback. LEAP 15.4 has a previous version of bluez (5.62) without the auto-enable package.
It looks like its behaviour is HW-dependent, so it worked for you (and @malcolmlewis ) but didn’t for me, but I have a Qualcomm/Atheros adapter known to be unfriendly.
With bluez 5.66 in TW everybody can find suitable settings apparently.

1 Like

That’s good to know, luckily for me that I found an easy fix I guess :smiley: Hopefully this tip can help others with this issue as well. Thank you for the help!

@OrsoBruno maybe some tweaking of /etc/bluetooth/main.conf may help for that device? The Dell device is all intel wifi/bluetooth…

Things get intriguing, installing bluez-auto-enable-devices fixes things in LEAP 15.4 and bluetooth on/off survives rebooting too.
With bluez 5.62 the config is a bit different, the relevant section of /etc/bluetooth/main.conf is the following:

# AutoEnable defines option to enable all controllers when they are found.
# This includes adapters present on start as well as adapters that are plugged
# in later on. Defaults to 'false'.

Apparently my Atheros adapter needs to be “enabled” at boot and possibly disabled by Gnome shortly afterwards, not being properly initialized otherwise I guess.
I updated the bug report accordingly.