Bluetooth disappeared after switching from Wifi to Ethernet

I have a strange problem. My computer supports Bluetooth and Wifi. I have used them both under OpenSUSE LEAP 15.2. Still, it appears that after switching to Ethernet instead of Wifi both of these technologies have stopped working or at least the system has stopped displaying any information about them. They don’t even appear in the normal place in KDE (bottom right).

I’m stumped on this one. I have no idea why one minute they were both working and the next they were not. I can understand Wifi going away as it is not needed because I am now using Ethernet, but why would Bluetooth go away at the same time? Any help to troubleshoot this issue would be appreciated.

Many WiFi chip sets also have the Bluetooth in them.
The Intel WiFi module on my Dell 7490 is one with both - if the WiFi is off so is the Bluetooth.
That may be the reason.

I use the MATE desktop so my display choices are different from Gnome 3, KDE and Wayland. It is more like Windows XP & Vista - Simpler is better for me.

Likely soft blocked (Fn+wifi key) they switch cycles through you can check via;

 0 wlan      phy0   unblocked unblocked
 1 bluetooth hci0     blocked unblocked

You can use rfkill to unblock if Fn key not working.

have you by accident swiched in YAST - Network - Network Settings - deactivated NetworkManager and switched to one of the other options? And did you configure the network adapter to work as DHCP ?

In two systems, I have an AX200 chip which does WiFi and Bluetooth. Turning it off stops both.

Instead of disabling the adapter, you can configure it not to connect to a network while it remains enabled.
Of course, this doesn’t help with battery-life if you are on a laptop since the combined WiFi and Bluetooth
chip will still be operating.

Note that for some reason, I have never managed to make NetworkManager work and am always using
Wicked which is perfectly fine on all three of my systems. So, the option of not connecting but leaving
powered on may be there in NetworkManager but I can’t be sure.

I tried this and Bluetooth isn’t listed. I also did this:

dmesg | grep Blue

and there was no output at all.

This statement only searches for "Blue’, nor for “blue”. Are you sure it is written eveyuwhere with a capital B? Ia have no idea, but maybe better use

dmesg | grep -i blue

Thanks for the tip. But still no output from that command.

Just to be sure ;).

I think then that it is indeed switched off as suggested above by others.

What is the status of bluetooth;

systemctl status bluetooth

OK. This is really weird if I run the following command:

systemctl status bluetooth

I get this output:

● bluetooth.service - Bluetooth service
   Loaded: loaded (/usr/lib/systemd/system/bluetooth.service; enabled; vendor preset: disabled)
   Active: active (running) since Tue 2020-10-20 15:12:39 BST; 3h 34min ago
     Docs: man:bluetoothd(8)
 Main PID: 19169 (bluetoothd)
   Status: "Running"
    Tasks: 1
   CGroup: /system.slice/bluetooth.service
           └─19169 /usr/lib/bluetooth/bluetoothd

and now when I run:

dmesg | grep -i blue

I get this output:

[13922.954630] Bluetooth: Core ver 2.22
[13922.954643] Bluetooth: HCI device and connection manager initialized
[13922.954646] Bluetooth: HCI socket layer initialized
[13922.954647] Bluetooth: L2CAP socket layer initialized
[13922.954648] Bluetooth: SCO socket layer initialized
[23455.585215] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[23455.585216] Bluetooth: BNEP filters: protocol multicast
[23455.585218] Bluetooth: BNEP socket layer initialized

But I haven’t changed anything yet. It seems to turn on and off on its own. But even with that output there is no bluetooth option in the bottom right of the KDE desktop.

I haven’t even restarted the computer.

Edit: Actually I do get the Bluetooth option now in KDE but it says no adaptors available.