Bluetooth Blues - can't get Bluetooth USB dongle to work

Hello,

based on the HW compatibility list, I bought a Conrad “Bluetooth Stick Micro” (Order number 97 19 99)
=> Does someone know, if this is “really” the one mentioned in the compatibility list ? Can I find out, what chip(set) is used ? (I’m somewhat “afraid”, that the name might be the same, but the chip(set) changed. No, it is unfortunately not mentioned in the documentation coming with it)

Unfortunately I didn’t get it to work on Suse 11.2 (64 Bit) so far.

This is what I tried:
Installed bluetooth packages, based on the information I found.
These are:

root@godot:~ # rpm -qa | grep -i blue
bluez-gnome-1.8-9.4.x86_64
kdebluetooth4-0.3-9.1.x86_64
bluez-4.56-1.1.1.x86_64
bluez-firmware-1.2-126.2.x86_64
libbluetooth3-4.56-1.1.1.x86_64
bluez-devel-4.56-1.1.1.x86_64
libgnome-bluetooth7-2.28.1-2.4.x86_64
gnome-bluetooth-2.28.1-2.4.x86_64
bluez-test-4.56-1.1.1.x86_64
bluez-hcidump-1.42-19.2.x86_64

I then checked the system and the installed packages for updates. After installing this I rebooted to make all changes active.

But when I now plug the USB dongle, I see no reaction in dmesg and I can’t see the device listed in lsusb output. (I compared “before” and “after” plugging)

=> Is my dongle simply defective ? I would have guessed I would have to see a reaction to plugging it in both dmesg and lsusb - even without any bluetooth specific SW installed.

I “blindly” tried “hcitool scan” (as described in some hints I found) but got:

root@godot:~ # hcitool scan
Device is not available: No such device

I looked for a bluetooth section in yast2, but couldn’t fine one. (I think I saw one in earlier releases…)
=> Did I miss it ? Do I miss a package ? (I checked all packages containing “yast” for something.)

So, with no yast2 module present, how do I do the basic configuration ? The documents I could find all describe how to use the bluetooth connection, if the basic setup suceeded.

All help and pointers welcome !

Martin

If it does not show up in the lsusb output, it is defective. I assume that you
have tried all your USB ports.

Hi
What about lsmod?


lsmod |grep bt
btusb                  15759  2
bluetooth              95999  10 hidp,rfcomm,sco,bnep,l2cap,btusb

and hciconfig


hciconfig
hci0:	Type: USB
BD Address: 00:22:43:AE:90:18 ACL MTU: 1021:8 SCO MTU: 64:1
UP RUNNING PSCAN
RX bytes:1020 acl:0 sco:0 events:35 errors:0
TX bytes:1350 acl:0 sco:0 commands:35 errors:0

In gnome there is an icon in the taskbar to add devices, when I
activate my BT mouse it pops up and ask to connect and away it goes on
my ASUS netbook.


Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 2.6.27.45-0.1-default
up 5 days 18:11, 4 users, load average: 1.74, 1.96, 2.10
GPU GeForce 8600 GTS Silent - CUDA Driver Version: 190.53

If it does not show up in the lsusb output, it is defective.

Ah, ok; I just wanted to make sure, before I try to get it exchanged.

I assume that you have tried all your USB ports.

Not all (too lazy :slight_smile: just two different ones:
One directly on the rear-connector of the mainboard. The one I tried there was even the one, I used before for a USB printer/scanner - without any problem. (I swapped this to another connector, simply for better accessibility at the rear)
Then second one on my USB hub on my desk. This one I always use for my USB memory stick - I rechecked just now: the memory stick works as expected.

What about lsmod?

Here is my output:

root@godot:~ # lsmod | grep bt
btusb                  20156  0
bluetooth             122404  1 btusb

Ah, thanks for the hint about “bt” - as you can see I always only grepped for “blue”.

and hciconfig

root@godot:~ # hciconfig
root@godot:~ #

Yes, simply no output at all.

Thanks for the info; think I will first try to have the dongle exchanged. (Maybe I can cross-check at a friend of mine - but this is 10 km away (by bicycle) on a rainy day…)

Martin

Hello,

yes, the bluetooth dongle simply was defective.
I got it exchanged and now it is working without any additional action necessary.
Just for the record: lsusb shows it as:

Bus 002 Device 004: ID 0a12:0001 Cambridge Silicon Radio, Ltd Bluetooth Dongle (HCI mode)

I can “see” my “Siemens” Gigaset SL 78H using Kbluetooth4.
I still fail to get a the “pairing” done. I will open a more appropriate named thread, if I need help on this.

Thanks for your help !

Martin

P.S.:
I will update the HW compatibility list with the details on the dongle.

Martin,

> I will update the HW compatibility list with the details on the dongle.

Maybe your stick is too “young”. Remember ‘/sbin/update-pciids’ and
‘/usr/sbin/update-usbids.sh’

I have an LevelOne MDU-0025USB H/W Ver.3.0 -> Bus 001 Device 006: ID
0a12:0001 Cambridge Silicon Radio, Ltd Bluetooth Dongle (HCI mode)

and it works

lemi@BLECHTROTTEL:~> list-devices
/org/bluez/3845/hci0 ]
Name = BLECHTROTTEL-0
Powered = 1
Devices =
DiscoverableTimeout = 0
PairableTimeout = 0
Discoverable = 1
Address = 00:09:DD:50:7E:8D
Discovering = 0
Pairable = 1
Class = 5898500

but I can’t get an rfcomm-Connection.

Lemi