bluetooth always turned off after reboot

OpenSuSE 13.2 with KDE
Dell Laritide E6530

Since Yesterday I could not connect my bluetooth mouse after a reboot
The little bluetooth Icon in the panel is available but the status is
Bluetooth turned off.

I can turn it on but on the next reboot it is turned off again
I am not aware of any config change and this is true be for all users
(including root)

Any ideas how I can fix this?

Regards

Klaus

Hi Klaus,

sorry, i can’t help, but i want to confirm your problem.

I am running openSUSE 13.2 (Harlequin) (x86_64), Linux 3.17.6-1.g12b7bf1-default, KDE4.14.3.

By the end of last week i updated my system (i believe that there was an update to bluedevil). Since then my bluetooth is always disabled on every system startup and i have to enable it manually.

I have not investigated this any further yet.

Best regards

susejunky

Check the ‘soft-block’ status with

rfkill list

I think the initial status has to do with the particular hardware and associated kernel acpi module (but could be wrong). I observe the same behaviour with my HP laptop (openSUSE 13.1, kernel 3.11.10-21-desktop), but it suits my needs and saves power too, as I don’t often use BT connectivity. Not a big deal to enable BT or 3G broadband connectivity manually when I need it.

# rfkill list
0: hp-wifi: Wireless LAN
        Soft blocked: no
        Hard blocked: no
1: hp-bluetooth: Bluetooth
        Soft blocked: yes
        Hard blocked: no
2: phy0: Wireless LAN
        Soft blocked: no
        Hard blocked: no
3: hp-wwan: Wireless WAN
        Soft blocked: yes
        Hard blocked: no
4: hp-gps: GPS
        Soft blocked: yes
        Hard blocked: yes

I have read about some distros employing a ‘systemd-rfkill’ service designed to restore the settings at boot. I wonder if that would help here?

http://www.freedesktop.org/software/systemd/man/systemd-rfkill@.service.html

I have read about some distros employing a ‘systemd-rfkill’ service designed to restore the settings at boot. I wonder if that would help here?

http://www.freedesktop.org/software/systemd/man/systemd-rfkill@.service.html

Further to this, can anyone confirm if openSUSE 13.2 now includes this service by default as part of systemd?

susejunky wrote:

>
> Hi Klaus,
>
> sorry, i can’t help, but i want to confirm your problem.
>
> I am running openSUSE 13.2 (Harlequin) (x86_64), Linux
> 3.17.6-1.g12b7bf1-default, KDE4.14.3.
>
> By the end of last week i updated my system (i believe that there was
an
> update to bluedevil). Since then my bluetooth is always disabled on
> every system startup and i have to enable it manually.
>
> I have not investigated this any further yet.
>
> Best regards
>
> susejunky.
>
>
Hi sesjunky,

Thanks for respoonding! Yes, this is exactly the same for me. I chceekd
the install history and there was an update for bluedevil at the 6th of
December.

Best Regards

Klaus

deano ferrari wrote:

>
> Check the ‘soft-block’ status with
>
> Code:
> --------------------
> rfkill list
> --------------------
>
> I think the initial status has to do with the particular hardware and
> associated kernel acpi module (but could be wrong). I observe the
same
> behaviour with my HP laptop (openSUSE 13.1, kernel 3.11.10-21-
desktop),
> but it suits my needs and saves power too, as I don’t often use BT
> connectivity. Not a big deal to enable BT or 3G broadband
connectivity
> manually when I need it.
>
> Code:
> --------------------
> # rfkill list
> 0: hp-wifi: Wireless LAN
> Soft blocked: no
> Hard blocked: no
> 1: hp-bluetooth: Bluetooth
> Soft blocked: yes
> Hard blocked: no
> 2: phy0: Wireless LAN
> Soft blocked: no
> Hard blocked: no
> 3: hp-wwan: Wireless WAN
> Soft blocked: yes
> Hard blocked: no
> 4: hp-gps: GPS
> Soft blocked: yes
> Hard blocked: yes
> --------------------
>
>
> I have read about some distros employing a ‘systemd-rfkill’ service
> designed to restore the settings at boot. I wonder if that would help
> here?
>
> http://tinyurl.com/ojoeahq
>
>
rfkill was not installed. The result after installing it running the
above mentioned command is:

0: dell-wifi: Wireless LAN
Soft blocked: no
Hard blocked: no
1: dell-bluetooth: Bluetooth
Soft blocked: no
Hard blocked: no
2: phy0: Wireless LAN
Soft blocked: no
Hard blocked: no
3: hci0: Bluetooth
Soft blocked: no
Hard blocked: no

On a logout / ligin the status seems to be kept but on a reboot it is
always turned off like susejunky noticed as well. I did not return back
to an older version of bluedevil.

Ok, so clearly not a rfkill issue then.

On a logout / ligin the status seems to be kept but on a reboot it is
always turned off like susejunky noticed as well. I did not return back
to an older version of bluedevil.

When you say BT is turned off, do you actually mean that you need to restart bluedevil, or something else?

What is reported by the following?

systemctl status bluetooth

Hi all,

in the meantime i looked a little bit closer into the problem and discovered another “change” introduced with the last update:

In KDEs system settings dialog for bluetooth there used to be a page where one could define a directory to keep incomming (via bluetooth) data and a second directory to share data via bluetooth. In my installation the latter part of the dialog is gone since i did the update last week.

@Klaus: Is that true for your installation as well?

I can confirm, that bluetooth stays on when i logout and login again. But on system restart it is always off.

@deano_ferrari: As you suggested i checked the rfkill status

# rfkill list
0: hci0: Bluetooth
        Soft blocked: no
        Hard blocked: no
1: phy0: Wireless LAN
        Soft blocked: no
        Hard blocked: no
#

Due to the result i have not investigated whether this http://www.freedesktop.org/software/systemd/man/systemd-rfkill@.service.html would help.

“systemctl” shows bluetooth is running. But there seems to be a problem:

#systemctl status bluetooth
bluetooth.service - Bluetooth service
   Loaded: loaded (/usr/lib/systemd/system/bluetooth.service; enabled)
   Active: active (running) since Mi 2014-12-10 09:12:40 CET; 1min 16s ago
     Docs: man:bluetoothd(8)
 Main PID: 719 (bluetoothd)
   Status: "Running"
   CGroup: /system.slice/bluetooth.service
           └─719 /usr/lib/bluetooth/bluetoothd

Dez 10 09:12:40 MACHINE bluetoothd[719]: Bluetooth daemon 5.23
Dez 10 09:12:46 MACHINE bluetoothd[719]: Starting SDP server
Dez 10 09:12:46 MACHINE bluetoothd[719]: Bluetooth management interface 1.7 initialized
Dez 10 09:12:46 MACHINE bluetoothd[719]: GAP and GATT are mandatory
**Dez 10 09:12:46 MACHINE bluetoothd[719]: gap-gatt-profile profile probe failed for xx:xx:xx:xx:xx:xx**
Dez 10 09:13:17 MACHINE.GRP bluetoothd[719]: Endpoint registered: sender=:1.28 path=/MediaEndpoint/A2DPSource
Dez 10 09:13:17 MACHINE.GRP bluetoothd[719]: Endpoint registered: sender=:1.28 path=/MediaEndpoint/A2DPSink                                                            
#

Nevertheless bluetooth works flawless after it is switched on in KDE.

Today i will try to return to the former bluedevil version.

Best regards

susejunky

deano ferrari wrote:

>
> Ok, so clearly not a rfkill issue then.
>
>> On a logout / ligin the status seems to be kept but on a reboot it
is
>> always turned off like susejunky noticed as well. I did not return
back
>> to an older version of bluedevil.
> When you say BT is turned off, do you actually mean that you need to
> restart bluedevil, or something else?
>
> What is reported by the following?
>
> Code:
> --------------------
> systemctl status bluetooth
> --------------------
>
>
I just have to right click the bluetooth icon in the panel and change
it to Turn Bluetooth On and than all is working fine / as expected.

Hi all,

i went back to bluedevil version 2.0~rc1-2.2.4 of the openSUSE 13.2 Oss repository. Now bluetooth behaves just as it did before i made the update last week:

  • bluetooth stays on even after a system on/off
  • KDEs system settings bluetooth dialog now others two settings again; one to define a directory where incomming (via bluetooth) data shall end up and a second directory to share data via bluetooth.
  • all incomming (via bluetooth) data ends up in the directory “/home/USER” no matter what is defined in KDEs system settings bluetooth dialog (the bug currently being worked on ?)

By the way:
With bluedevil version 2.0-23.1 all incomming (via bluetooth) data now ends up in the directory defined in KDEs system settings dialog for bluetooth!

I guess that the error shown in the output of systemctl

# systemctl status bluetooth
bluetooth.service - Bluetooth service
   Loaded: loaded (/usr/lib/systemd/system/bluetooth.service; enabled)
   Active: active (running) since Mi 2014-12-10 09:12:40 CET; 1min 16s ago
     Docs: man:bluetoothd(8)
 Main PID: 719 (bluetoothd)
   Status: "Running"
   CGroup: /system.slice/bluetooth.service
           └─719 /usr/lib/bluetooth/bluetoothd

Dez 10 09:12:40 MACHINE bluetoothd[719]: Bluetooth daemon 5.23
Dez 10 09:12:46 MACHINE bluetoothd[719]: Starting SDP server
Dez 10 09:12:46 MACHINE bluetoothd[719]: Bluetooth management interface 1.7 initialized
Dez 10 09:12:46 MACHINE bluetoothd[719]: GAP and GATT are mandatory
**Dez 10 09:12:46 MACHINE bluetoothd[719]: gap-gatt-profile profile probe failed for xx:xx:xx:xx:xx:xx**
Dez 10 09:13:17 MACHINE.GRP bluetoothd[719]: Endpoint registered: sender=:1.28 path=/MediaEndpoint/A2DPSource
Dez 10 09:13:17 MACHINE.GRP bluetoothd[719]: Endpoint registered: sender=:1.28 path=/MediaEndpoint/A2DPSink
# 

was related to the fact, that my Android device was not in reach, when bluetooth got started. Therefore this might not be related to the problem discussed here (or probably does not represent a problem at all).

Best regards

susejunky

Hi,
a quick fix has been provided at http://forum.linux-club.de/viewtopic.php?f=92&t=119795 That post is in German. The main point is that the issue is most likely due to the new version of bluedevil not controlling the power-state of the hci device. If that’s a bug is unclear at present. Anyway, to get that functionality back, you don’t need to downgrade your bluedevil version, instead a udev rule seems to be sufficient:

/etc/udev/rules.d/10-local.rules
# Set bluetooth power up
ACTION=="add", KERNEL=="hci0", RUN+="/usr/bin/hciconfig hci0 up"

For me this works with opensuse 13.1 and bluedevil-2.0-23.1.x86_64. The udev rule has been ‘borrowed’ from https://wiki.archlinux.org/index.php/bluetooth#Bluetoothctl, where additional expert’s tweaking of hci can be taken from.

wbwb