bluetooth adapter not power off after a shutdown

i got a new mb asus prime b250m-a
i installed from zero a 15.1

when i shutdown my pc with kde menu i get a surprise : usb bluetooth adapter is not powered off, randomly usb card reader is not powered off.

i must use the switch at the rear panel to power off the 2 devices.

the bluetooth adapter is connected to a usb 2.0 external connector (itself connected to an internal usb 2.0 10.1 pin connector).

the card reader is connected to a usb internal 3.0 20-1 pin connector.


  • last kernel problem
  • driver problem

if you get a solution thanks in advance.

USB ports generally have +5VSB available even when in S5 (shutdown state)

Check you MB bios settings, there may be an option to disable it.

Okay thanks to tannington

I found some explanations.

Today new PC (desktop, laptop) get a new feature : when PC is shutdown then USB connector stays power supplied according to charge USB devices. Nice but no so. USB keyboard, mouse, card reader, Bluetooth adapter or their drives must be smart enough to detect this state and to switch off by themselves. This is not the case.

I installed the Broadcom driver of my Bluetooth adapter supplied by Pluggable. This swithes off the led when shutdown but it remains an emitted very tiny light.
Then in my case I went to bios. I searched USB power settings. i found in “embedded devices settings” a setting “Charging USB devices in power state S5” with value “enable”. I change the value to “disable” then no more problem for my Bluetooth adapter and my card reader.

OK - Good to hear you’ve resolved the problem.

May I ask about your Star Tech card reader?

Is it the 35FCREADBU3 model?

I ask as I was thinking of purchasing that model, but have read several reviews that mention having problems with the pins in the CF slot, effectively rendering it unusable. As it’s CF cards I would be using primarily, I’ve rather been dissuaded from making the purchase. I wonder if you’ve had any problems in that respect.

It is the internal model

I never used the CF slot. I only use the SD and micro SD slot without any problem and satisfaction because the reader using usb 3.0 is very fast.

Right, OK then. Thanks anyway… :slight_smile:

i got an answer from ASUS.

He asks for me to change in APM settings the value of “ErP ready” from “disable” to another value"enable for S4" or “enable for S4/S5”.

I re-enable “USB charging” and set “ErP ready” to “enable for S4/S5”. The card reader and Bluetooth adapter are switch off when shutdown PC.

The “ErP ready” feature is a standard to guaranty that when you shutdown a PC (or any device consuming energy for example a washing machine) PC consumes less than 0.5 W.

If you set “enable for S4/S5” to "enable for S4/S5 then all PME devices are disabled. I checked that “USB charging” was disabled by this feature.

I am not sure to understand meaning of “enable for S4/S5” and PME.

Anyway this works.