Bluedevil - sending data from computer?


I have a question regarding Bluetooth with Bluedevil. Finally I got a connection working in one direction: sending files from my mobile (Google Nexus One with Android 2.3.3) to the computer. But I can not send files from my computer to the phone.

I also tried to send files from my desktop to my Laptop and it fails. I also tried it the other way around: from Laptop to Desktop… fail.

What is it? Is it still a bug in Bluedevil and all I can do is wait? Or is there some package missing?

the following packages (regarding bluetooth) are installed:

libbluetooth 3

I don´t believe that it is hardware related, because it works one-way… If I should post logfiles or whatever, just tell me…

thanks for some answers on that!


I’ve only just recently installed bluedevil (KDE4.6.2, openSUSE 11.3) for my work phone bluetooth connectivity. I’m interested in the answer to this question as well. (I’m about to have a play with sending files over the next day or so).

I’ve just tried dragging and dropping via dolphin from my home directory to my ‘obexftp://00-24-7c-4a-5b-9a/E:/Images/’ location. This worked without issue.

However, if I use the ‘Send files’ function from the systemtray icon, it doesn’t appear to work properly (at least with my phone).

Anyway, I have these installed as well (not sure what is actually required):



I think this is a step towards the solution. I have installed these packages now. But what do I have to do then in Dolphin, to get this obexftp:// ??

I just have an entry in the left side panel with Bluetooth. Before installing the obex-packages there was nothing in there and when Dolphin scanned for external devices, it did not find anything. When I open the folder now, it finds my mobile after scanning. But when I drag&drop something there, nothing happens.
Also when I drag & drop something on the mobile phone icon: nothing… When I open the mobile phone icon in Dolphin, I find a file, named “Send file”. When I double click on it, Dolphin does not know what type this file is.
When I drag & drop something on this file, nothing happens. When I right-click on the “Send File” file, I can choose “open with Bluedevil send file”… but then the send file wizard of Bluedevil opens and it can not send files… there is no connection to the phone.

I also tried this between computers. So sending a files from the Laptop to the desktop also fails.

But sending files from the mobile phone to both computers works like a charme…

so do I need to set up Dolphin in a certain way, or what do I need to do?

thank you very much!


I don’t remember having to do anything special. However, maybe you could start over with BlueDevil’s ‘Add device’ (via Bluetooth icon in system tray). That will start the wizard which should discover your mobile phone. One of the options you can then configure (enable) is ‘Send file’ (which allows you to send files to the remote device).

BTW, clicking on the Bluetooth icon in Dolphin’s places panel is equivalent to entering ‘bluetooth:/’ URL in the location bar. If I do this, my bluetooth phone connection icon appears, and clicking on that causes ‘Browse Files’ and ‘Send file’ icons to appear. (The location bar then contains ‘obexftp://00-24-7c-4a-5b-9a/’)

Now, if I really want to send files, I just choose ‘Browse Files’ and navigate to the desired folder. Dragging and dropping files to that directory cause the files to be uploaded. Selecting the ‘Send file’ icon starts the ‘Bluetooth Send File’ window, but although I can select a file to send, and it attempts to connect with my phone, it doesn’t appear to send it (and I don’t get to choose a target directory either). The first method works for me and that’s what counts.

does not work for me. I don´t get this “browse files” icon. I also tried it with a computer of a friend (running openSUSE 11.3) and he gets the “browse files” icon sometimes but not always. Thats what I found out in the meantime, after I did my “what do I have to do for the obexftp entry” post. On my computer it never worked so far. Anyway… sending from the phone works. Maybe I get another Bluetooth adapter and try it again (assumeing that it is hardware related) or I leave it like it is.

Thank you for help!

FWIW, there is a KDE bug report on this:

Interestingly, there is a package obexd-client that is mentioned. Try installing that, then check bluetooth send file behaviour again, and report back. Maybe that’s all that is missing.

Alternatively, try the blueman package, and see if that works for you. :slight_smile:

This is work in progress for KDE4 it seems.

Thats was it! I’m using openSUSE11.3, and the obexd-client package wasn’t available from the 11.3 OSS repo (although obexd was). Anyway, I risked installing both from the 11.4 OSS repo, and I now have the ability to send files using the ‘Send File’ option. I’m sure it will work for you too.

So, now I have these installed

linux-n35n:/home/dean # rpm -qa |grep obex

Great stuff! :slight_smile:

hmm I am not sure about this… because obexd-client requires obexd and this requires Evolution-data-server and lots of other packages… I will end up with half of the Gnome desktop, just because of Bluetooth. Maybe in some days I open my mind about this and install it anyway :smiley: but right now I am more in the mood to wait for KDE 4.7 and to hope that it will be fixed then.

With KDE 4.6 they did the first step, sending from the phone never worked too before… I have tested Blueman already in 11.3 some weeks ago and it did not work either. I am getting more and more in the direction of Hardware… it is maybe a hardware problem. With Ubuntu, this Bluetooth adapter also did not work right and also not with Fedora…

So I´ll check the hardware at first, buying a new adapter. And if this is no solution, I´ll go for obex-client :smiley:

hmm I am not sure about this… because obexd-client requires obexd and this requires Evolution-data-server and lots of other packages… I will end up with half of the Gnome desktop, just because of Bluetooth.

Well, I do have evolution and evolution-data-server installed (although I’m not using them) and obviously some gnome packages as a result, but these were dragged in by previous package dependencies (ie not as a result of the obexd packages).

So I´ll check the hardware at first, buying a new adapter. And if this is no solution, I´ll go for obex-client

Ok, keep us informed anyway. If I could convince you, it would be to close your eyes and try the latter though :slight_smile:

okay - you convinced me :smiley:

it works! when I rightclick on the Bluetooth icon in the taskbar and choose “send file” with my phone, it works. But it does not work in Dolphin - choosing the bluetooth folder…

anyway… Thank you very much! :smiley:

okay - you convinced me…
anyway… Thank you very much!

My pleasure to assist. I’ve learned a bit doing this to, and gained better bluetooth functionality, so I’m happy.

If you think something is not working as well as you’d have expected, please consider filing a bug report with KDE and/or Novell.

Found this thread

I have exactly symptoms as here:
Except that I can not send file from command line

~> obexftp -b F8:DB:7F:CE:93:59 -p Documents/file.jpg
Browsing F8:DB:7F:CE:93:59 …
Connecting…failed: connect
Tried to connect for 4ms
error on connect(): Invalid argument
Still trying to connect
Connecting…failed: connect
Tried to connect for 4ms
error on connect(): Invalid argument
Still trying to connect
Connecting…failed: connect
Tried to connect for 6ms
error on connect(): Invalid argument
Still trying to connect

Pair phone - no problems.
Receive file from phone - no problems

Send file to phone - FAIL. Progress starts in the tray but never ends
Phone is Android 2.2 smartphone

Is there any other workaround to transfer file from openSUSE box to phone?

~> rpm -qa | grep obex

~> rpm -qa | grep blue

KDE, openSUSE 11.4

Bus 004 Device 002: ID 03f0:171d Hewlett-Packard Wireless (Bluetooth + WLAN) Interface [Integrated Module]
Device Descriptor:
bLength 18
bDescriptorType 1
bcdUSB 2.00
bDeviceClass 224 Wireless
bDeviceSubClass 1 Radio Frequency
bDeviceProtocol 1 Bluetooth
bMaxPacketSize0 64
idVendor 0x03f0 Hewlett-Packard
idProduct 0x171d Wireless (Bluetooth + WLAN) Interface [Integrated Module]
bcdDevice 1.00
iManufacturer 1 Broadcom Corp
iProduct 2 HP Integrated Module


Oh, found a way how to make command line working
This issue was Android-related. There is a setting in the mobile phone to enable FTP server (which does not make sence). If file browsing is enabled you can now send file from command line. But from KDE Bluedevil - still does not work. But this bug is already reported

Hope this will help anybody


anyway… I think, there is one package missing on your machine: obexd-client. That is what I needed to get it running on my computer.

steffen13, you were right
After installing obexd-client, obexd and a lot of its’ dependencies - now KDE’s bluetooth file sending works fine. Thanks for the tip!

Thanks for the update. It does drag in a few other seemingly unnecessary packages, but it gets the bluetooth file management working as desired! :slight_smile: