Blue Yeti Microphone Undetected

My microphone is not detected by openSUSE, meaning I can’t use it. It shouldn’t be a problem with the microphone itself since I have been able to use it on other operating systems and devices. I’ll list what I’ve tried below.

I have checked pavucontrol for it. Nothing.

I ran

arecord -l

with the following output:

**** List of CAPTURE Hardware Devices **** 
card 0: SB [HDA ATI SB], device 0: ALC898 Analog [ALC898 Analog] 
  Subdevices: 1/1 
  Subdevice #0: subdevice #0 
card 0: SB [HDA ATI SB], device 2: ALC898 Alt Analog [ALC898 Alt Analog] 
  Subdevices: 2/2 
  Subdevice #0: subdevice #0 
  Subdevice #1: subdevice #1 
card 2: C920 [HD Pro Webcam C920], device 0: USB Audio [USB Audio] 
  Subdevices: 1/1 
  Subdevice #0: subdevice #0

You can see my webcam showing up as card 2, meaning that my computer is recognising some USB devices. I have also tried plugging my microphone into other USB slots. Nothing there either.

Any help would be most appreciated as I can’t seem to find anything online about this kind of error. Usually the error tends to be that the user failed to recognise that the device was detected but only muted. That’s unfortunately not my problem here.

Post:

lsusb

Now disconnect the Micro, open an terminal and as root:

journalctl -f

Now connect the Micro and post the new message in the terminal here in Code-Tags.

lsusb:

Bus 005 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub 
Bus 011 Device 002: ID 2433:b111 ASETEK 690LC 
Bus 011 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub 
Bus 010 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub 
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub 
Bus 009 Device 003: ID 04f3:0103 Elan Microelectronics Corp. ActiveJet K-2024 Multimedia Keyboard 
Bus 009 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub 
Bus 001 Device 005: ID 046d:082d Logitech, Inc. HD Pro Webcam C920 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub 
Bus 008 Device 002: ID 046d:c332 Logitech, Inc. G502 Proteus Spectrum Optical Mouse 
Bus 008 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub 
Bus 007 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub 
Bus 006 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub 
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub 
Bus 003 Device 002: ID 0781:5575 SanDisk Corp. Cruzer Glide 
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

journalctl -f

[FONT=monospace]-- Journal begins at Mon 2021-07-19 19:21:18 CDT. -- 
Jul 21 11:43:24 localhost.localdomain systemd[1374]: app-flatpak-io.freetubeapp.FreeTube-27999.scope
: Deactivated successfully. 
Jul 21 11:43:24 localhost.localdomain systemd[1374]: **app-flatpak-io.freetubeapp.FreeTube-27999.scope**
: Consumed 1h 47.376s CPU time. 
Jul 21 11:58:28 localhost.localdomain konsole[10750]: **kf.notifications: Playing audio notification f**
ailed: Destroyed 
Jul 21 11:58:28 localhost.localdomain systemd[1374]: app-org.kde.konsole-3a2e604aa9d8413b8742277a98f
a60fd.scope: Deactivated successfully. 
Jul 21 11:58:28 localhost.localdomain systemd[1374]: **app-org.kde.konsole-3a2e604aa9d8413b8742277a98f**
a60fd.scope: Consumed 4.740s CPU time. 
Jul 21 11:58:30 localhost.localdomain systemd[1374]: Started Konsole - Terminal. 
Jul 21 11:58:42 localhost.localdomain sudo[29103]: **gkr-pam: unable to locate daemon control file** 
Jul 21 11:58:42 localhost.localdomain sudo[29103]: gkr-pam: stashed password to try later in open se
ssion 
Jul 21 11:58:42 localhost.localdomain sudo[29103]: **   ahsto : TTY=pts/1 ; PWD=/home/ahsto ; USER=roo**
t ; COMMAND=/usr/bin/journalctl -f 
Jul 21 11:58:42 localhost.localdomain sudo[29103]: pam_unix(sudo:session): session opened for user r
oot(uid=0) by ahsto(uid=1000)



[/FONT]

Interestingly, nothing changed after plugging in the USB…

See here, its the USB Controller:
https://bugzilla.suse.com/show_bug.cgi?id=1188485

You can try the kernel from Post#6 or kernel:stable.

Oh, I see. Does this basically mean switching out the OS? How exactly do I change the kernel, and to which one specifically?

(sorry for all of the basic questions)

Tumbleweed will get the next kernel from kernel:stable.

So it it safe but has some regressions:
You have to disable secure boot in BIOS/UEFI
you can not use the kernel modul packages (kmp) from the Tumbleweed Distribution.
But the patched kernel is building and will maybe tomorrow in the Repo.

So if you do not use broadcom-wl, Nvidia-kmp or virtualbox from Tumbleweed Repo, no regression for you
But you can get this packages from another Repo…

Or use the tiwai Repo until kernel 5.13.5 will be delivered.

PS:
I use kernel:stable:backport here on Leap 15.3, backport because of the regression of factory packages to build the kernel in Leap 15.3…

I was able to solve this issue by just installing the

pulseaudio

package. Make sure to choose the option that deletes pipewire. Then just reboot and it should work.

Hi,…what I do see is with this model blue yeti is that it takes a bit longer to be perceived when stopped back in.

Also, my different gadgets streak drove while booting up, the sasquatch remains on, no sound…just the drove.

I tried this with my PC and it is by all accounts working fine when awakening from rest mode.

In any case, on my PC it doesn’t remember it when awakening. the drove is on, no solid, no mic.

Important that my console additionally requires a significant stretch of time to boot up, consequently that I need another console to enter the BIOS.

Makes me believe it’s not BIOS related.

I also have new Tumbleweed issues with a USB headset/microphone: https://bugzilla.opensuse.org/show_bug.cgi?id=1189701 .

Please open a new thread.