Blu-ray player for opensuse?

opensuse tumbleweed

Does there exist a blu-ray player for opensuse that can play commercial blu-ray content?

I have searched the forum; the most recent posting about this was in 2014. A web search found makeMK; it works, but is tedious to wait 90 minutes while it rips the media (the version available in the repo does not stream).

I just use VLC. Works fine.

1 Like

I tried VLC. It would not play the content.

Please tell us the response VLC gave when you tried to play the disc.

Do you have libdvdcss/libdvdcss2 installed? This is a requirement for most commercial/protected DVDs/BluRays…
The libdvdcss repository can be added/activated via yast software → community repos…

May be you are missing some packages like libaacs, libbluray-bdj, libbluray, …

Try installing VLC trough the community repositories and try again. As others pointed out, it could be a codecs issue.

Hah! I did at one time. It is no longer and it is not available in the repo.

So I installed libdvdcss2. VLC now starts to load the disk contents, shows an image, the movie name, crashes. So it is possible VLC will play a BD, just not that one.

It is in the repo
which you can add with

zypper ar -f libdvdcss

AFAICT all of the libraries are installed, and now includes libdvdcss.

VLC ( is installed from Packman. Is that not sufficient?

Is KEYDB.cfg installed in ~/.cache/aacs/? (Name is case sensitive.) If not, get it from and change keybd to KEYDB. If KEYDB.cfg is installed, search it for the title you are trying to play. If the key is not available, the disc will not play.

Correcting myself.

It would be better to use:

zypper ar -f$releasever/ libdvdcss

as that might make it easier for a future upgrade to Leap 15.6


There was no .cache/aacs/ folder. I created it, downloaded KEYDB, watched a movie.

Thank you all for your help!

I tried this. Tumbleweed does not do $releasevar.

It does, but not usefully.

In any case, I gave you the URL for the repo for Leap 15.5, which was my mistake. For Tumbleweed, use: