Blizzard app

So Blizzard stopped supporting Windows xp, now Windows 7 is needed.
I have 32-bit prefix, and things that are described on wineHQ:
+Winetricks with many dlls.

However there is a Bug:

Wine 2.0.1 is not enough? Xp was the only os that worked.

It’s interesting, why they stopped support. Was that really technically not possible.

XP is 16 years old and abandoned by Microsoft already, as XP is no longer supported in WoW or any of their games either so it makes sense launcher has dropped support for it too.

Yes, I know this, abandoned some years ago… Xp was the only setting that worked for me:(. We’ll see if latest Wine works.

What game are you trying to play? I’m playing Heroes of The Storm and It’s working fine for me with playonlinux and wine 2.0.13 (win7).

Not sure about Playonlinux, it does something useful additionally? Its based on Wine. Encountered many typos. Maybe it has installed some required dll or component for you to run this game? Want to run almost every game actually, but app itself crashes.
I have installed: corefonts, binkw32.dll, d3dx10_43, d3dx11_43, d3dx9_24 to 42 (perhaps too many), directx9 (usually overkill), dontnet40, ffdshow, ie8, l3codecx, mfc42, msls31, msvcirt, pngfilt, vcrun2005, vcrun2008, vcrun2010, vcrun 2012, vcrun2013, vcrun2015, vcrun6sp6, vcrun6, uh:|, wininet, xact, xinput, xmllite, xvid. Version is set to Win 7 32-bit. And permissions should be fine already because it worked before.

There are also options in winetricks that I may have missed, and playonlinux doesn’t let me use prefix that already exists, even with import plugin.

Well, i dont know why it doesn’t work and doubt anyone will be eager solving this strange problem!
glistwan’s stable wine works though.
When running through terminal, it keeps showing messages like these:

fixme:file:MoveFileWithProgressW MOVEFILE_WRITE_THROUGH unimplemented
fixme:msvcp:_Mtx_init_in_situ unknown flags ignored: 2
fixme:ntdll:NtLockFile I/O completion on lock not implemented yet
fixme:ntdll:EtwEventUnregister (deadbeef) stub.
fixme:ntdll:NtQuerySystemInformationEx Relationship filtering not implemented: 0x3
fixme:winsock:WSAIoctl unsupported WS_IOCTL cmd (SIO_SET_COMPATIBILITY_MODE)
err:virtual:map_file_into_view failed to set 00000007 protection on file map, noexec filesystem?
err:virtual:map_file_into_view failed to set 00000005 protection on file map, noexec filesystem?

Not sure about the errors. Playonlinux doesn’t do anything that wine can’t do but it’s just easier(for example you can use different wine versions for different programs). It’s actually wine 2.17 staging that works for me:

It’s a bit late for the reply, but Blizzard announced that it will cease not only supporting, but running it’s programs on anything older than Windows 7 in October:

idk I tried to say just that:) But 1 classic game still does work no matter what.
Repos, primary ones missing new Wine Stable 2.0.3