Blinking Dash After 11.1 Install

I was previously running three OS on one home built computer. Windows XP, Ubuntu SE 8.04, and Mac OSX86. They were all running fine and booting correctly using GRUB in Ubuntu. I decided, what the hell, why not install OpenSuse. I have two hard drives. One is 160GB and contains solely Mac. The other is a 750GB drive containing XP, Ubuntu, and hopefully OpenSuse. I install OpenSuse with GRUB, because I like the layout of it more, and it seemed to go fine. I had unplugged the Mac drive, as to not hurt it if things went wrong. After the install, I tried to boot and after the chance to get into the BIOS, I am left at a screen with just a blinking dash. I thought I would see if Mac worked… Unfortunately it had the same problem. I also tried booting from the install DVD and then boot from the harddrive, this did not work either. I would really appreciate it if I could get a few tips on making this work. I would love to use OpenSuse. Thanks. If you have any questions or want specs, please ask.

Are still booting with the other drive unplugged?

No. Neither of the drives are booting correctly. No matter what combination they are plugged in.

Yikes. That doesn’t sound right. Well, assuming the OS X drive booted on it’s own before that?

Do you have a live cd? Boot it with both drives connected. When you get to the live desktop, open a terminal and become su and do:

fdisk -l

post result with as much explanation as possible

YAY!!! It was really odd… When I booted with both HDs attached it came up with the Ubuntu’s Grub!! I didn’t even use the live cd… I will just leave it at that and try to add in OpenSuse to it and see what happens. Thank you very much for the help!