Blinking cursor at boot

Today I decided to play with my new 11.4 Opensuse dvd. It installed and booted without any problem, and I didn’t face any problem until I rebooted the computer to test my newly installed nvidia graphics drivers. openSuse wouldn’t boot.
Well, the important side is: there are no kernel panics, no “hit enter to restart computer” to find the reason. Just a blinking cursor after an attempt to find the kernel. I only could get out of that by pressing the reboot button.
I decided to press c and boot manually:

grub> root (hd0,4)
Filesystem type is ext2fs, partition type 0x83
grub> kernel /boot/vmlinuz-

and the computer just froze. At this stage pressing tab for autocompletion at kernel line freezes the computer, too.

Any ideas? Maybe additional boot parameters?

Well, considering that installation brought me to a desktop, the system seems to be up and ready to run. Nothing seems wrong with my menu.lst:

title openSUSE 11.4
    root (hd0,4)
    kernel /boot/vmlinuz- root=/dev/sda5
    initrd /boot/initrd-

(I did not install a bootloader with openSUSE. This is legacy grub bootloader of Debian)

So I am somewhat confused by the minimal setup your have. Compare your entry here to mine which follows.

title openSUSE 11.4     
root (hd0,4)     
kernel /boot/vmlinuz- root=/dev/sda5     
initrd /boot/initrd-

The main point is the kernel load option nomodeset, that you will see here with other default settings.

###Don't change this comment - YaST2 identifier: Original name: linux###
title Desktop -- openSUSE 11.4 - 2.6.39-0.5
    savedefault 0
    root (hd0,0)
    kernel /boot/vmlinuz-2.6.39-0.5-desktop root=/dev/disk/by-id/ata-INTEL_SSDSA2M080G2GC_CVPO037603KN080JGN-part1 resume=/dev/disk/by-id/ata-Hitachi_HDS721010CLA332_JP9921HD2SSJLH-part2 splash=silent nomodeset quiet showopts vga=0x34a
    initrd /boot/initrd-2.6.39-0.5-desktop

Now much of the commands are specific to my setup such as drive names and the nomodeset was added by me to allow the nVIDIA driver to install and load. In particular I would add the following commands from my listing “splash=silent nomodeset quiet showopts”.

Thank You,

Thanks for your reply. Those minimal parameters worked for me with many distros: no bootsplash and default settings.

Anyway, I tried the settings I’ve found in /etc/sysconfig/bootloader and the settings you’ve provided for me, but no avail. I’ve never passed the blinking cursor.

The installation media is good:

md5sum  /dev/sr0 
5f6d6d67c3e256b2513311f4ed650515  /dev/sr0

It’s the same with this.

Anyway, ignore this. I’ll try to re-install later.

On 06/01/2011 03:06 AM, onekine wrote:
> Any ideas? Maybe additional boot parameters?

my guess is you will find a smile here: (or

but, no promises as i’m also somewhat perplexed spryness by your Debian

you may wanna consider these strings, they fit my system but may smoke
yours so read my sig’s caveat and scratch your head first…

from /boot/grub/menu.lst normal boot:

title Desktop -- openSUSE 11.4 -
root (hd0,5)
kernel /boot/vmlinuz-
splash=verbose quiet showopts ipv6.disable=1 vga=0x314
initrd /boot/initrd-

note, that string allows a many viewing of the normally hidden work
behind the green splash, and also disables IPv6 (which speeds up
connecting with the still mostly v4 web)


title Failsafe -- openSUSE 11.4 -
root (hd0,5)
kernel /boot/vmlinuz-
showopts apm=off noresume nosmp maxcpus=0 edd=off powersaved=off
nohz=off highres=off processor.max_cstate=1 nomodeset x11failsafe vga=0x314
initrd /boot/initrd-

and by the way, our grub is not the same grub used by *buntu, ours is
also ‘legacy’…try it, you might like it…

[NNTP via openSUSE 11.4 [] + KDE 4.6.0 + Thunderbird 3.1.10]
Dual booting with Sluggish Loser7 on Acer Aspire One D255

On 2011-06-01 03:06, onekine wrote:
> (I did not install a bootloader with openSUSE. This is legacy grub
> bootloader of Debian)

I’m not sure that is wise. Better install grub in the root partition of
openSUSE, and just add an entry on the debian grub to load openSUSE grub.
This way, when you run updates on oS it will be happy when it updates grub
entries. Both systems thus mantain their own grub, no interference.

Cheers / Saludos,

Carlos E. R.
(from 11.2 x86_64 “Emerald” at Telcontar)