Bleachbit fails to start after update - "GdK-CRITICAL"


Just updated a TW 64bit KDE and after rebooting I wanted to start Bleachbit, but it doesn’t come up. In the console I get:

~> bleachbit
scandir is not available, so falling back to slower os.walk()

(process:14934): Gdk-CRITICAL **: 09:58:17.415: gdk_screen_get_root_window: assertion 'GDK_IS_SCREEN (screen)' failed

Nothing in dmesg.

I have

python 2.7.17-7.1

bleachbit 3.2.0-2.1 (from:

I found this, but what does it mean?

The proposed

xhost +

doesn’t help (same output in consle’). Neither does “sudo bleachbit”…

Any ideas?

PS: I updated two KDE TW yesterday, there Bleachbit is just doing fine…

The problem seems to be that bleachbit can not do graphical output.

Can you become root (su, not sudo) and give it a try?

If it does not work, try running as root “xclock”, does that work?

su and sudo give same error.

su xclock

gives “user does not exist”.

Fun fact: I updated a Leap 15.1 (4.12.14-lp151.20.40-default) with KDE and Bleachbit won’t start with the same error in the console.


That is not what he suggested you to do (he apparently assumed you understand how to use su).

He in fact asked you to do


after which you enter the root password and then do the statements “as root”.

And please read

man su

to understand why su says hat the user (xlock) does not exist.

BTW, to both you and @marel, I strongly advice to use

su -

instead of plain su. It is not as dangerous as it was earlier because they added code to avoid the worst, but it is still better (and also a good habit) to use the --login, or shortend to -l, or further shortend to - option.
When in KDE, you can also start Konsole as Superuser from the main menu. It includes su - usage.

For Tumbleweed your own your own for python2 application…

Ask the maintainers to see if it’s python3 ready?

  119s] Requires: /usr/bin/python /usr/bin/python2

Are you running the 3.2.0 version as this was fixed with an entry;

Fix: work without X session and without GTK package

Hi Malcolm!

As in the OP: Yes, 3.2.0. But won’t work.

What do you mean by:

For Tumbleweed your own your own for python2 application....

Had another 129 something Updates with zypper dup today, didn’t help.


In dmesg I have on reboot

Failed to start Virtual Console

…I will freeze version 2.2 on all machines still having it.

Is there any way to go back to 2.2 on the machines already “updated” (downgraded) to version 3?

Yepp, xclock works just fine after doing su - :slight_smile:

Saw just that there is another Bleachbit thread listing the same error:

I see there is no official Bleachbit package yet for TW while there is for Leap 15.1.
How did you install Bleachbit on TW?

See OP, it’s from utilities repo. I tried to install old 2.2 from there, but apparently it’s not there anymore…

Python2 is deprecated in Tumbleweed and slowly disappearing along with any apps that don’t upgrade/work with python3.

…but I have the same error on a Leap. This doesn’t add up.