Blank screen using Nvidia drivers, nv driver works fine

Hello all,

I have just installed OpenSUSE 11.2 on an Intel DQ35JO motherboard and XFX 9500GT 512MB video card. After installation the desktop looked fine on the Sony LCD TV I have connected to the 9500GT via a DVI to HDMI cable.

After the first reboot after installation I added the Nvidia repository via the add community repository function in the software sources option in YaST2. I then proceeded to install the Nvidia G02 drivers and the nvidia-settings package. At this point after a reboot I would get a blank screen. Hitting ctrl-alt-F1/F2/F3/F4/F5/F6 has no effect, I could not get any of the virtual consoles to appear. I had to SSH into the box and reboot into runlevel 3.

Once I had rebooted into runlevel 3 I logged in as root and executed “sax2 -r -m 0=nvidia” and got an error message that the configuration server could not be started. I tried executing “sax2 -r -m 0=vesa” and received the same error:

xc: sorry could not start configuration server
xc: for details refer to the log file

    /var/log/SaX.log

xc: abort...

The relevant part of /var/log/SaX.log seems to be:

        (==) Log file: "/var/log/Xorg.0.log", Time: Thu Dec 10 14:48:14 2009
        (++) Using config file: "/tmp/sax2-4320/xorg.conf"
        Parse error on line 104 of section Device in file /tmp/sax2-4320/xorg.conf
        This section must have an Identifier line.
        (EE) Problem parsing the config file
        (EE) Error parsing the config file

        Fatal server error:
        no screens found

        Please consult the The X.Org Foundation support
         at http://wiki.x.org
         for help.
        Please also check the log file at "/var/log/Xorg.0.log" for additional information.

Line 104 of /tmp/sax2-4320/xorg.conf is:

Section "Device"
  Driver       "nvidia"
EndSection

(It’s actually the line with “EndSection” in it.

/var/log/Xorg.0.log contains the same error at the end of the file:

(==) Log file: "/var/log/Xorg.0.log", Time: Thu Dec 10 14:48:14 2009
(++) Using config file: "/tmp/sax2-4320/xorg.conf"
Parse error on line 104 of section Device in file /tmp/sax2-4320/xorg.conf
        This section must have an Identifier line.
(EE) Problem parsing the config file
(EE) Error parsing the config file

Fatal server error:
no screens found

Please consult the The X.Org Foundation support
         at http://wiki.x.org
 for help.
Please also check the log file at "/var/log/Xorg.0.log" for additional information.

(WW) xf86CloseConsole: KDSETMODE failed: Bad file descriptor
(WW) xf86CloseConsole: VT_GETMODE failed: Bad file descriptor

Even executing “sax2 -r -m 0=nv” produces the same error.

If I execute “modprobe nvidia” and then “sax2 -r -m 0=nvidia” the PC locks up hard. The CPU fan spins up to full speed and I can no longer ping or SSH into the box.

However, if I reboot into runlevel 3 and remove the Nvidia drivers via yast2 and reboot then I can get back into the desktop.

I’ve done lots of googling and all the posts I’ve found seem to indicate that all I need to do is install the Nvidia drivers and run sax2. It doesn’t seem to work for me though.

Do any of you have any suggestions that I could try?

Thanks,

Higgers.

I have searched through the forum and found someone posted with a similar problem. Here’s some info that may be helpful diagnosing the issue:

zypper lr -d | grep NVIDIA
1  | download.nvidia.com-opensuse        | NVIDIA Repository                           | Yes     | Yes     |   99     | rpm-md | ftp://download.nvidia.com/opensuse/11.2/
uname -a
Linux lounge 2.6.31.5-0.1-desktop #1 SMP PREEMPT 2009-10-26 15:49:03 +0100 x86_64 x86_64 x86_64 GNU/Linux
lspci | grep nVidia
01:00.0 VGA compatible controller: nVidia Corporation G96 [GeForce 9500 GT] (rev a1)
rpm -qa *nvidia*
nvidia-gfxG02-kmp-desktop-190.42_2.6.31.5_0.1-8.2.x86_64
x11-video-nvidiaG02-190.42-9.1.x86_64
nvidia-settings-190.36-0.pm.2.4.x86_64
rpm -qa *kernel*
kernel-desktop-2.6.31.5-0.1.1.x86_64
rpm -qa *kmp*
nvidia-gfxG02-kmp-desktop-190.42_2.6.31.5_0.1-8.2.x86_64
preload-kmp-desktop-1.1_2.6.31.5_0.1-6.9.1.x86_64

Thanks,

Higgers.

Changing to the -default kernel and nvidia drivers made no difference.

On 12/10/2009 11:36 AM, higgers was rumored to have said:
> Changing to the -default kernel and nvidia drivers made no difference.
>
>

I had a somewhat similar problem and think what messed me up was that I
hadn’t done a update before I installed the driver. I can’t prove it,
but it’s a theory. So having said that, I would suggest you try the
following.

Uninstall the nvidia packages:
zypper rm nvidia-gfxG02-kmp-desktop x11-video-nvidiaG02

Update with:
zypper up

Then re-install:
zypper in nvidia-gfxG02-kmp-desktop x11-video-nvidiaG02

optional: run “nvidia-xconfig”

Now restart the xserver and cross your fingers!

Here are the results:

zypper rm nvidia-gfxG02-kmp-desktop x11-video-nvidiaG02
Retrieving repository 'openSUSE BuildService - KDE:KDE4:Community' metadata [done]
Building repository 'openSUSE BuildService - KDE:KDE4:Community' cache [done]
Retrieving repository 'openSUSE BuildService - Mono:Community' metadata [done]
Building repository 'openSUSE BuildService - Mono:Community' cache [done]
Retrieving repository 'openSUSE BuildService - OpenOffice.org' metadata [done]
Building repository 'openSUSE BuildService - OpenOffice.org' cache [done]
Retrieving repository 'Packman Repository' metadata [done]
Building repository 'Packman Repository' cache [done]
Loading repository data...
Reading installed packages...
'nvidia-gfxG02-kmp-desktop' is not installed.
Resolving package dependencies...

The following packages are going to be REMOVED:
  nvidia-gfxG02-kmp-default x11-video-nvidiaG02

2 packages to remove.
After the operation, 84.3 MiB will be freed.
Continue? [y/n/?] (y):
Removing x11-video-nvidiaG02-190.42-9.1 [done]
Additional rpm output:
------------------------------------------------------------------------
Switching the use of "nvidia" driver of NVIDIA to "nv" driver of X.Org
------------------------------------------------------------------------

Patching /etc/X11/xorg.conf ... done


Removing nvidia-gfxG02-kmp-default-190.42_2.6.31.5_0.1-8.2 [done]
zypper up
Loading repository data...
Reading installed packages...

Nothing to do.
uname -a
Linux lounge 2.6.31.5-0.1-default #1 SMP 2009-10-26 15:49:03 +0100 x86_64 x86_64 x86_64 GNU/Linux

I had the default kernel installed so installed the default nvidia driver:

zypper in nvidia-gfxG02-kmp-default x11-video-nvidiaG02
Loading repository data...
Reading installed packages...
Resolving package dependencies...

The following NEW packages are going to be installed:
  nvidia-gfxG02-kmp-default x11-video-nvidiaG02

2 new packages to install.
Overall download size: 16.7 MiB. After the operation, additional 84.3 MiB will
be used.
Continue? [y/n/?] (y):
Retrieving package nvidia-gfxG02-kmp-default-190.42_2.6.31.5_0.1-8.2.x86_64 (1/2), 2.5 MiB (25.3 MiB unpacked)
Retrieving: nvidia-gfxG02-kmp-default-190.42_2.6.31.5_0.1-8.2.x86_64.rpm [startiRetrieving: nvidia-gfxG02-kmp-default-190.42_2.6.31.5_0.1-8.2.x86_64.rpm [0% (0 Retrieving: nvidia-gfxG02-kmp-default-190.42_2.6.31.5_0.1-8.2.x86_64.rpm [3% (23Retrieving: nvidia-gfxG02-kmp-default-190.42_2.6.31.5_0.1-8.2.x86_64.rpm [21% (3Retrieving: nvidia-gfxG02-kmp-default-190.42_2.6.31.5_0.1-8.2.x86_64.rpm [45% (5Retrieving: nvidia-gfxG02-kmp-default-190.42_2.6.31.5_0.1-8.2.x86_64.rpm [72% (4Retrieving: nvidia-gfxG02-kmp-default-190.42_2.6.31.5_0.1-8.2.x86_64.rpm [88% (1Retrieving: nvidia-gfxG02-kmp-default-190.42_2.6.31.5_0.1-8.2.x86_64.rpm [done (283.1 KiB/s)]
Installing: nvidia-gfxG02-kmp-default-190.42_2.6.31.5_0.1-8.2 [done]
Retrieving package x11-video-nvidiaG02-190.42-9.1.x86_64 (2/2), 14.2 MiB (59.0 MiB unpacked)
Retrieving: x11-video-nvidiaG02-190.42-9.1.x86_64.rpm [done (356.3 KiB/s)]
Installing: x11-video-nvidiaG02-190.42-9.1 [done]
Additional rpm output:
------------------------------------------------------------------------
Switching the use of "nv" driver of X.Org to "nvidia" driver of NVIDIA
------------------------------------------------------------------------

# SaX generated X11 config file
Patching /etc/X11/xorg.conf ... done
Warning! MD5DIR is not set: you probably called this script outside SuSEconfig...!
Using MD5DIR="/var/adm/SuSEconfig/md5"...
No changes for /etc/X11/xdm/Xservers
No changes for /etc/X11/xdm/xdm-config

The above was all done after booting into runlevel 3. Executing “init 5” at this point resulted in a hard lockup. The CPU fan immediately started running at full speed and I had to hit the reset switch.

After the computer had again booted into runlevel 3 I executed “nvidia-xconfig” and then executed “init 5” and again got a blank screen, however, it’s now possible to SSH into the box.

I can’t see what I’m doing that is different to anyone else who has encountered this issue and solved it using nvidia-xconfig and/or sax2!

Thanks for your help,

Higgers.

Actually, from your previous post:

uname -a
Linux lounge 2.6.31.5-0.1-desktop #1 SMP PREEMPT 2009-10-26 15:49:03
+0100 x86_64 x86_64 x86_64 GNU/Linux

This shows you have the desktop kernel loaded. Try again and install the
desktop version this time. And let’s hope it works this time.

I feel you pain brother. This shit can be frustrating sometimes…

This is prob going to sound really silly but if it’s KDE i had the same type of problem, It’s fixed by renameing the /.kde folder or removing it, then rebooting, it should load a default KDE desktop… it happens a lot when certain settings are changed and the activation of 3d effect’s.

I have had it in gnome with Compiz Enabled but that would still atleast boot to a GUI.

In post #5 above the output of uname -a was:

uname -a
Linux lounge 2.6.31.5-0.1-default #1 SMP 2009-10-26 15:49:03 +0100 x86_64 x86_64 x86_64 GNU/Linu

I had the -default kernel loaded.

I feel you pain brother. This **** can be frustrating sometimes…

I think I must have done something bad in a past life! :wink:

I believe the contents of the .kde folder would only become relevant if I managed to login to KDE? I can’t even get that far. If I boot to runlevel 5 the usual text scrolls up past the top of the screen and then instead of the KDM login screen appearing I just get a blank screen.

Anyway, I tried moving the .kde folder from both /root and from the single user in /home but it made no difference.

Thanks,

Higgers.

The same problem occurs with Ubuntu 9.10. After installing the restricted drivers and rebooting the machine when the GDM screen should appear the machine locks up and the CPU fan immediately runs at full speed. I’m beginning to suspect a hardware problem now. :confused:

As opposed to typing “init 5” did you try a simple restart ? There is always the possibility (however very very very slight) that “init 5” is failing to start a process that a nominal reboot will start.

Is this boot direct to run level 5 (and not via “init5” command) with the nvidia-xconfig created xorg.conf ? or with the sax2 xorg.conf ? or both ?

Yes, I’ve tried rebooting several times since my last post. Still no success. Very strange.

I’ve tried rebooting into runlevel 5 with an nvidia-xconfig xorg.conf with no success. “sax2 -r -m 0=nvidia” errors before it can create an xorg.conf. If I uninstall the nvidia drivers and delete xorg.conf then I can boot into runlevel 5 and login into KDE without problem.

Clearly this is very nVidia driver specific. You could try posting about this on the nVidia forum for Linux:
NVIDIA Linux - nV News Forums

It seems to me like there’s something peculiar about this particular PC. I believe I’ve installed the drivers correctly.

I’ve updated the BIOS on the motherboard, changed the RAM, removed all other PCIe cards, etc. I’ll try the 9500GT in another PC to try and determine if the hardware is faulty.

On 12/11/2009 8:36 AM, higgers was rumored to have said:
> It seems to me like there’s something peculiar about this particular PC.
> I believe I’ve installed the drivers correctly.
>
> I’ve updated the BIOS on the motherboard, changed the RAM, removed all
> other PCIe cards, etc. I’ll try the 9500GT in another PC to try and
> determine if the hardware is faulty.
>
>
One other question, do you have an onboard graphics gpu? If so, have you
tried enabling that to see if you have the same problem? Also, if you
can post the output of Xorg.0.log. In my case, I actually saw in the log
that it completely failed to load the driver. If that’s the case for
you, then you can eliminate the card as the problem.

I do not believe this is your machine having an issue. Yesterday I ran through a similar situation:

I currently run a dual opteron 2354 system on a Tyan 2915 board with 3ware raid and 8GB ram with the 9500 GT 512MB by evga.

Running OpenSuSE 11.1 w/ nvidia 9500 GT was just fine (except for some development work and issues with python and the RT kernels…)

Wiped out root partition and installed 11.2. Install worked great. Executed the reboot at the end of install…hard lockup.

I figured it was a quirk with 11.2…installed Ubuntu Studio 9.10…same behavior.

Frustrated and tired of troubleshooting, I installed my BFG 7300 GT in tandem with my 9500 GT…nothing. It hard locked on X initialization again.

I removed the 9500 GT and used the 7300 GT…it booted up. I looked in /etc/X11 and there was NO xorg.conf file. I installed the 180 version nvidia driver from the nvidia website, not repos. Ran the nvidia-xconfig and rebooted with the 7300 GT and it was still working.

I powered down and reinstalled the 9500 GT…booted up and started X just fine. I checked nvidia-settings and in the list of devices it showed both the 7300 GT and 9500 GT as active. I plugged the monitor into the 9500 GT DVI port and it worked.

I powered off, removed the 7300 GT, plugged both monitors back into the 9500 GT and booted up. Presto, back in business.

rotfl!

My question for the forum is this:

What happend in X such that no xorg.conf file is present with these new releases? May it have been a failed install step or a new version of X that is supposed to autodetect all configs, but failed?

OK people. First, /etc/X11/xorg.conf is no longer needed. The errors clearly show that there is a parse error due to a missing identifier line. That would be like this:

Section “Device”
Identifier “Nvidia”
Driver “nvidia”
EndSection

but, as said xorg.conf is no longer needed.

You may want to install the most recent beta driver “the hard way”. Don’t run nvidia-xconfig, so you will leave the configuration to the system.