Blank Screen on Reboot

In my post, I was trying to make clear that although the GPU is different, there was/is a bug I’ve seen that looks identical to the described problem.

That doesn’t automatically mean the causes are identical, but likely suggests a promising path of investigation.


Could you check if you have anything under /sys/class/backlight? May be it is enough to simply turn backlight on.

Sorry for my delayed reply. Last night I did try fiddling around with the settings under /sys/class/backlight. They didn’t seem to have any immediate impact, but I decided to try rebooting once more, and somehow, this time, it worked. I’m frustrated because I’m not sure if it was changing the settings in the backlight directory that did anything, or if it magically fixed itself… but it appears to be fine for now! If it happens again, I’ll post back here with any further progress I’ve made.

Thanks to everyone for your help on this - it’s very much appreciated. Cheers!

Just changing the setting would not work right away. You have to restart things ie reboot.

I didn’t realize that - perhaps that was the solution then. I’ll keep that in mind. Thanks!

That’s rather blanket statement. For all I know, writing into “brightness” attribute normally takes effect immediately. Do you know and can quote any system that requires reboot? Or could you explain what exact attribute under sysfs you mean?

I assumed the change was to a config file which requires a restart to activate the change.