Blank screen & mouse after bootup

I just installed 11.3 on a Toshiba Satellite A305 laptop. After going through the install process it restarted (without a full reboot I believe) and spent a very long time going through a bunch of message. E.g. it spends about 10-15 minutes building java fonts, and warning me that Japanese/Chinese/Korean might not work in Java.

About 20+ minutes after bootup it finishes with all the status messages (including a message that said it couldn’t execute /usr/bin/cmp !?) and goes to a blank screen with a mouse sprite – first a spinning circle, then a regular arrow sprite. So it’s not a totally black screen, but all I have is the mouse sprite.

I let it sit there for over an hour. I think it was hitting the disk but nothing happened. I tried rebooting and it did the same thing. I tried setting the “nomodeset” boot parameter, which had helped someone with a similar problem – no change. I tried it in failsafe mode – no change.


Did you do this with the install media - before install:

Hm. No. Is it common to get bad downloads? I downloaded it from a torrent.

I tried to do the verify but it gets about 60% through loading the kernel and the laptop shuts down. But that doesn’t necessarily indicate a problem with the OpenSUSE media because the same laptop did the same thing loading the Windows 7 installer.

So I downloaded md5sums.exe for Windoze and the checksum (for the ISO, before it’s burned onto the DVD) is OK. I don’t know of any other way to checksum the DVD itself.

I kept trying and got it to load the verifier kernel. No errors on the install DVD.

Now what?

Well, nevermind I guess. This is my 15-yr-old’s laptop and I was trying to help him to install OpenSUSE on it. I came back from running an errand and he had Ubuntu running on it. He said it installed without a hitch. Ohwell…

He changed his mind again. :slight_smile: I got back from work and he’d decided he didn’t like Ubuntu so he installed OpenSUSE again – and apparently figured out what had gone wrong the first time. He said he found a warning somewhere that OpenSUSE wouldn’t work properly if you installed it in too large a partition. He repartitioned it to two 110GB partitions, and I guess the install went smoothly then. Whether that was the cause of the problem or whether he just got lucky this time, I don’t know for sure, but he’s up & running now.

Sound good news then… Thanks for keeping us informed…

Had the blank screen with only mouse problem, too. I think it happens when you have 3d desktop effects enabled but the graphics driver cant handle it.
To be more precise: I used default nouveau driver, enabled compiz 3d effects, had issues and so restarted with nomodeset kernel parameter which forces driver nv with no 3d -> got blank screen with gnome and kde, but normal screen in other window managers without 3d effects.

Doesn’t sound like our problem. I don’t think I ever enabled any fancy features like that, since we never got it running after the install. All we ever got was the blank screen. And I tried nomodeset, and failsafe, and that didn’t change anything.