Blank Screen after logging in opensuse 11.1

I am new to linux . I have followed step by step installation for the opensuse 11.1 i selected kde 4.1 as desktop

I used the dvd .

Everything went as per the installation guide but when system rebooted after installation a command line showed up asking for login . I inseterd my user and pass which it asked during installation .

it sucessfully logged in . But no gui desktop .

I pressed ctrl+ alt+ f7 a blank scree appears with a cursor blinking.

If i press ctrl+alt+f2 again its asks for login in the comand line.

System :amd sempron 2500+
512 mb ram
gigabyte mother board

Thanks

Hey Hyddec,

Try this link: Configuring graphics cards.

That should help you install and configure your graphics card drivers.

Not having them installed is one of the most common reasons for the error you are having.

I hope that helps you out! :slight_smile:

hey thanks for that but When its blank i cannot browse .

I got other system where i am using windows . So i got the file downloaded to usb but need assistance .

Thanks alot

You could try failsafe boot, see if that gets you to a GUI, otherwise I can show you how to switch to vesa. Try failsafe and report back

Hi hyddec. For new users, trying to work from console only is like working in the dark. You may be able to get a basic desktop up (using vesa graphics driver) by choosing ‘failsafe mode’ at grub boot menu.

Alternatively, try this from command prompt:

su (to become root user)
sax2 -r -m 0=vesa (configure xorg to use vesa driver).

When done, try rebooting and see if you get a desktop.

Once you have a graphical desktop, you can then set about installing a proprietary graphics driver.

Hey thanks guys,

I selected the failsafe i got the desktop.

So what graphics device do you have?

the dislpay adapter is VIA/S3G UNichrome pro igp

I tried to setup the network using yast2 with root password but no use.

network card : via/Rhine ( i see its detected)

Look here, there a re links to all the different hardware areas
Hardware - openSUSE

But I’m not sure what you best option with that graphics is? Probably Vesa, which is kinda basic.
The ethernet should work.

Open a terminal and type: su
then your root password

now do:

lspci -v

post results

well did it . but still i need to login through failsafe for desktop .

or same blank screen.

ethernet detected but no connection.

I think you are best to start a new thread with respect to your network connectivity.

I don’t know much about VIA graphics, except to expect pretty limited performance. Try configuring at runlevel 3. Type these commands into a console

su (to become root,enter root password when prompted)
init 3 (kill the X-server and enter console mode)

You can try configuring graphics permanently with ONE of the following:

sax2 -r -m 0=via
sax2 -r -m 0=vesa

When configured, do

init 5

to return to runlevel 5 (with graphical desktop)

Edit: Did find this openSUSE VIA guide. It suggests configuring as vesa first, then hand-editing xorg.conf to use via driver. See how you go.

I have given this command su (to become root user)
sax2 -r -m 0=vesa

Its working fine in normal mode i dont have to select failsafe anymore.

Thanks a lot

Thanks i will do that i reply back here .