blank screen after install

After installing I get a blank screen after it says preparing for 1st intial configuration. I am not using an AMD card like most the others I’ve read that have this problem, it’s an integrated intel card. I tried the boot option 3 and get to login I type in my login and password and it says it’s invalid. I’m not sure if it’s because it didn’t finish configuring since it never got past the initial configuration after rebooting from the install or what. I’m getting so frustrated I want to throw the computer out the window.

Calm down:)
Most intel cards work quite well, but some are problematic. You could try deselecting the automatic config here:
This should enable you to manually configure the display settings. Using vesa for the display might be worth trying as it’s universally OK even if basic.

There is also a VESA and TEXT mode install which may help you get a little further.

Further to what caf4926 noted, there have been some changes in openSUSE-11.2 affecting the graphic driver. Still, despite those changes, the graphic should work.

First, please read what the 11.2 release notes have to say:

YaST and X.Org Configuration (Keyboard, Mouse, Graphics Board, and Monitor)

In the past, YaST offered an configuration interface for the graphical desktop ( such as keyboard, mouse, graphics board, and monitor. During the installation a suitable xorg.conf was created.

In most cases it is no longer needed because the Xserver is now able to automatically configure the system. If it fails for your system, try the following steps:

    1.  Check whether an old /etc/X11/xorg.conf file exists. If so, move it away and start your desktop again.
    1.  If it still does not work, run sax2 from the command line and execute the configuration procedure.
    1.  To adjust hardware components to your personal needs, start the GNOME desktop control center or Configure Desktop in KDE, and configure your devices such as the mouse or keyboard. The display configuration dialogs also let you configure multiple monitor setups. To configure multiple monitors, in other desktop environments, use xrandr. 

For more information, see the Desktop User Guides shipping with openSUSE. They are also available from Documentation - openSUSE

The program “sax2” they refer to in step 2 is a program that will automatically create the file /etc/X11/xorg.conf , which can be used to configure your graphics. Now the organization “xorg” who code X window, are gradually moving away from the need to have an xorg.conf file, and Novell/SuSE-GmbH are trying to follow that philosophy for 11.2 and hence for many users openSUSE-11.2 does not need an /etc/X11/xorg.conf file. BUT when the automatic graphics does not work, the solution is often to create such a file with “sax2”.

Often it helps to give sax2 an input value so as to assist it in its automatic creation of the /etc/X11/xorg.conf file.

The techinque is to boot to what is called “run level 3” (a text interface with internet access capability but no gui). You can boot to “run level 3” by pressing the “3” key (no quotes) when the boot menu 1st shows up (that is where you select openSUSE, openSUSE fail safe, Windows, etc … the “3” will appear in the options line). It will take you then to a text login, and you should then login as a regular user. Then after logged in, type ‘su’ to switch users to the administrator and enter root password. Then as root, type:

sax2 -p

to determine what graphics device is identified (post that here). Then for an intel graphic device, you could try the intel driver:

sax2 -r -m 0=intel

(that is zero equals intel) and test your graphics. If that appears to work, you can restart with “shutdown -r now” with root permissions. Does that work?

If not, go into run level 3 again, and this time try the “vesa” driver. You can do that by typing:

sax2 -r -m 0=vesa

(that is zero equals vesa). Again, if that appears to work, you can restart with “shutdown -r now” with root permissions. Does that work?

The only problem is that it seems like it isn’t accepting my username and password that I set since I can never fully make it through the install. So when I do the option 3 boot, I get to the login and password and get denied access. I seriously regret offering to install this for my friend. I had him setup with ubuntu and he recently brought it back to me because of the latest upgrade he couldn’t log in. So I thought I’d let him try out opensuse now, and can’t get past this.

Note that Linux is case sensitive. Hence the password “MyPassword” is different from “mypassword”.

I know it’s case sensitive and I know exactly what I typed for the password. I’ve tried installing it on 3 occasions now with the same result. Without getting past the “preparing 1st configuration part” which at point I get the black screen and frozen icon, I can’t seem to login via command line.

screw it… I’m done messing with his POS computer. I’m just going to pull his hard drive and put it in another computer I have lying around. I’m fed up with working on it and getting no where.

OK, try caf4926’s suggestion of VESA for install:

You can also try the “text” install. Once it is complete, you will still have a graphical GUI.

Note thou, before you installed, it was imperative that you

  • compared the md5sum of the downloaded iso file against the md5sum posted on the web site; and
  • burned the installation CD/DVD to high quality media (an RW is NOT recommended) at the slowest speed your burner allows
    *]take note of the fact that the calibration of the CD/DVD drive on old PCs can be so bad that sometimes they won’t work with the CD/DVD burned on a new PC (in which case its best to burn the CD/DVD from the same PC in which the install is planned)

the vesa install gave me the black screen as well. I didn’t even bother wasting any more time with the text install. I’ve wasted too much time on this pc as it is.