i installed ati driver with one click install and after rebooting i get a blank screen what should i do
and what exactly went wrong this time, i really like linux but every time something happens and it really is shaking my loyalty towards linux

On Mon, 24 Aug 2009 03:06:01 +0000, calanor wrote:

> i installed ati driver with one click install and after rebooting i get
> a blank screen what should i do

Start the system in runlevel 3 (at the boot menu, type “3” and then
select the menu option). Once that’s done, login as root and try:

sax2 -r

That will start the hardware auto-detection again. Go through the
configuration, and when done, either type:

init 5

To start the GUI, or:

init 6

To restart the system.

> and what exactly went wrong this time

Hard to say without more information about the hardware in use, and
messages from the X log files.


Jim Henderson
openSUSE Forums Moderator

i tried sax2 -r but it turns off my monitor after showing a distorted init 3 screen
i tried aticonfig --initial but i get the same distorted display but the monitor remains on

i think i have found the problem in debug mode it’s working fine and the kernel version was 2.6.19.x and the kernel version of all other modes were 2.6.7or.9
so how can i upgrade from 2.6.9 to 2.6.19

2.6.9 to 2.6.19?

Which distro is this?

Indeed, I note:

OpenSUSE-11.1 =>
OpenSUSE-11.0 =>
OpenSUSE-10.3 =>
OpenSUSE-10.2 =>
OpenSUSE-10.1 =>
OpenSUSE-10.0 => 2.6.13
SuSE-9.3 =>
SuSE-9.2 => 2.6.8
SuSE-9.1 => 2.6.4
SuSE-9.0 => 2.4.21

I wonder if that is a typo, and he means from to ? … although if so, he needs to note that the kernel is now at

I think so…its a typo error.

sry i forgot to add .27
i messed it all up so i reinstalled 11.1,updated it and then one click installed the driver i dropped into init 3
typed sax2 -r -m 0=fglrx restarted everything was working fine but then i enabled desktop effects and now my pc is down to a crawl how can i revert my settings and how to get those effects
my graphics card is ati hd 3650
and my machine is quite capable of handling the effects

edit /etc/X11/xorg.conf

the very last section

Section “Extensions”
Option “Composite” “on”

Change to

Section “Extensions”
Option “Composite” “off”

That should disable desktop effects and get you back to speed. Next you need to read up on your particular ati device before trying again. I’m a nvidia user, so I’m not well up on ati:
ATI - openSUSE

Beagle can have that effect. You could check to see if it is installed, and if it is, remove any application with beagle in the application name.

but beagle was enabled before and by crawl i mean i just can’t use it i have to reset also the taskbar switches transparancy continuously

i could’nt find entry for composite in xorg.conf

i uninstalled beagle zypper rm beagle
so i am not able to work in the normal mode
so i entered failsafe but here i can not get to gui
tried sax2 -r -m 0=vesa but computer hangs

Its possible you have an rpm with “fglrx” in the name that is interfering with the load of the vesa driver. Can you check if that is the case?

You can do that by typing (and advising the output of):
rpm -qa | grep fglrx

Also, some PCs graphic cards require forcing the vesa driver to a lower resolution, with something like:
sax2 -r -l -m 0=vesa
and that assumes there is ONLY one graphic card/device on the PC.

i don’t know how but after trying sax2 -r it’s working with effects only the fonts are a bit ugly but i think it’s okay thanks for your support

Glad to read its working now. Out of curiousity, what graphic driver are you using? You can find that out by opening a terminal and typing:
grep -i driver /etc/X11/xorg.conf
and then post here the output

Driver “kbd”
Driver “evdev”
Driver “mouse”
Driver “fglrx”

Ok, thanks. Thats pretty clear. Your PC is using the proprietary ATI graphic driver “fglrx”.

that slowdown thing happens randomly now,sometimes i can work perfectly
sometimes i have to use windows

i posted the above msg from opensuse and this i am posting from windows because after rebooting opensuse desktop froze again