Blank screen after 10 minutes

I have the problem (11.3) that the screen is blanked after 10 minutes (console and KDE).
After some searching, I found out, it is a kernel “feature”. Since it is a server, which should display network status permanently on screen this behavior is fatal.
I have tried:

  • switch of power features vie Grub kernel param: apm=off, powersaved=off
  • in kde via screensaver options
  • in term “setterm -blank 0”

nothing did help. How can I kill this nasty kernel feature. It drives me cracy :\


In KDE got to menu / Personnel Settings / Advanced / Power Management. Make sure that “Let PowerDevel manage screen powersaving” IS checked. Next go to edit profiles, select the profile you are using, such as performance when plugged in and go to the Screen Tab and make sure that “Enable display power management” is NOT checked. Next got to menu / Personnel Settings / General / Desktop / Screen Saver. Either select a screen saver here or make sure the screen saver is disabled.

Thank You,

I solved this problem with a script that is run at startup. Here is the code:

#! /bin/bash

xset s noblank -dpms
exit 0

Call it whatever you want and put it in the autostart section of Configure Desktop > Advanced > Autostart > Add Program with the full path.


thank you for your suggestions, but none of them worked for me.
Monitor is still blanking after 10 minutes. Also the console. :’(

Do you have some more ideas?


Could this be the monitor itself?

no - since I had the problem not under 11.2. Moreover the monitor is connected via KVM serving a few servers.

can’t test since i do not have 11.3, but here is a possible:

11.3 turn off screensaver

CAVEAT: [posted via NNTP w/openSUSE 10.3]

I replied to that thread but this is overly complicated. KDE devs don’t care about the endusers one darned bit anymore. I still don’t know how to stop screen blanking. I’ll just hope I lucked out with this non intuitive multi-tab configuration nonsense. This has me in the rant mode I am sorry.

On Tue, 07 Sep 2010 22:36:02 +0000, FlameBait wrote:

> KDE devs don’t
> care about the endusers one darned bit anymore.

Knowing a few of the KDE developers, I can say this is emphatically not
true. However, they do realize (as any developer with a large userbase
will) that they can’t please everyone. So you should take note that
just because YOU don’t like it (and YOU can find others who don’t like
it), that doesn’t imply (and it doesn’t logically follow) that the devs
don’t care about the users.

That kind of hyperbole really doesn’t help anyone.

> This has me in the rant
> mode I am sorry.

Then you should post to soapbox in order to get it out of your system.


Jim Henderson
openSUSE Forums Administrator
Forum Use Terms & Conditions at

Screen blanking after 10 min is usually the Kernel screen blanker kicking in. I don’t know why on some systems this kernel option is turned in. I never did find how to reliably turn it off in 10.1 one I had the problem. 11.2 on the same hardware does not do it.

This what worked for me in KDE 4.4 on my desktop computer.
From the application manager go to.
Personal Settings Configure Desktop > Desktop>Screen Saver all boxes unselected.
Personal SettingsConfigure Desktop > Advanced > Power Managment > Edit Profiles > Performance > Screen >Enable display power management box is checked. Standby after checked and set to zero minutes. Suspend after box is check and set for zero minutes. Select apply.

My monitor has yet to blank after being left on for several hours.

Hello Everyone,
tried everything but no solution yet. still blanking console and X.
I have tried all suggestions made here and checked it several times. No success. Is there maybe a kernel parameter?