Blank monitor after booting up - probably driver problem


I see the opensuse boot progress bar just fine when the monitor turns blank when the X server would start up. I believe the root cause lies in the fact that I added the AMD repo to the list in YAST, as the current official driver is incompatible with the current kernel.

Unfortunately I don’t know how I am supposed to remove this bad repo from the list when even the other terminals are blank. I’ve thought of using a live DVD but I don’t know how to target an update to the installed system instead to the current live system?

Thanks for any suggestions!

Hi jluber,

I am having the same problem… It started after I installed a kernel update last night, and a pop-up informed me that I needed to reboot a soon as possible! Bad idea. As far as I can make out, the new kernel is not compatible with the ATI screen drivers, and I am going to have to recompile them so that I can get back up and running. Are you using an ATI Graphics card? I assume that you are seeing as you have an AMD processor.

Will post back and let you know as soon as I have tried it. If you find the solution before me, please post back and let me know what you did.


Dredger wrote:
> As far as I can make out, the new kernel is
> not compatible with the ATI screen drivers, and I am going to have to
> recompile them

hmmmmm…i can’t tell you why your update didn’t go like mine, but i
let the OpenSUSE Updater do all the work and it automatically:

-downloaded and patched two kernels (default, and PAE)
-downloaded the new kernels’ source (or maybe just headers)
-compiled and installed the new Nvidia drivers…

hands-off, out of the box, it just worked! (using 10.3 and KDE 3.5.7)

i’m a happy camper!!

Linux linux103-32 #1 SMP 2009-05-27 10:35:34
+0200 i686 athlon i386 GNU/Linux

I would try starting up in failsafe mode. It uses the vesa driver. From there you can use yast software manager to remove the offending driver package and repo.

Alternatively, from the grub menu, enter ‘3’ then return to start up in runlevel 3 (without desktop). You can log in as root and do

sax2 -r -m 0=vesa

Then do

init 5

to start up graphical desktop environment

Ok, I have got it all back up and running!

During the boot process, at the Grub boot splash screen, before the timer runs out, type “init 3” and press enter.

This should log you into console mode.

Log in as root, and then browse to the directory where you stored you ATI graphics driver. (If you don’t have it, download it. Post if you need help…)

Now run the driver with the following command, and be sure to agree with everything and use all default settings. Don’t use the Distro specific build…

(Replace the ati-driver-… with the version you downloaded/use)

Once you finish that type the following.

aticonfig --initial -f

Now type

sax2 -r -m 0=fglrx

This should take you into the sax config setup. Agree and save.

Type reboot to reboot…

And that is what I have done!!! Hope that it works for you.


Thanks Dregder,

I’ve tried following your instructions (I’ve found the ATI download page). Unfortunately the driver installation fails. This is the fglrx-install.log:

[Message] Kernel Module : Trying to install a precompiled kernel module.
[Message] Kernel Module : Precompiled kernel module version mismatched.
[Message] Kernel Module : Found kernel module build environment, generating kernel module now.
AMD kernel module generator version 2.1
kernel includes at /usr/src/linux/include not found or incomplete
file: /usr/src/linux/include/linux/version.h
[Error] Kernel Module : Failed to compile kernel module - please consult readme.

Furthermore there is a meesage that a file couldn’t be overwritten. I guess that is the actual driver file but I didn’t manage to catch the directory it resides in. Further ideas?

Hay jluber,

Ok, lets see… Please bare in mind that I am still feeling my way around Linux so I may be taking the longer route around this than is necessary. If someone else has any advice please feel free to pitch in here.

So… Having said that, this is what I would advise you to try!

Firstly, lets make sure that you have an ATI graphics card.

Type: lspci
Look for the VGA compatible driver. If it is an ATI Driver, great. If not what is it? nVidia? Assuming that it is, go to the ATI webpage and check the compatability list on the download page. I know that my Radeon X1200 has recently been moved to the older hardware list and that I now need to download the 9.3 driver and not the newer 9.4… Make sure that you have downloaded the correct driver. Ok, now lets assume that you have and are in init 3, have logged in as root, and have browsed your way to the directory where the downloaded driver is.

Now lets resolve any kernel update dependencies…
zypper in kernel-source gcc make patch

You should now have to wait while zypper connects to the net and updates all kernel sources to what you are going to need.

Once that is done, you can once again try to install the driver.
So modifying the following to your correct driver name, type in the same as my previous post:


Followed by:

aticonfig --initial -f

Followed by:

sax2 -r -m 0=fglrx

Now reboot, and post back to tell me how that went.


I have a parallel windows installation. I checked the catalyst centre for the card info (ATI Radeon 4800) so my confidence is high to have downloaded the right thing. As I can access my computer only next Monday again, I’ll have to wait to try the rest of your post.

I tried the fglrx driver in the ati repo. I was greeted with a blank screen on reboot. I removed it using Yast --ncurses. Next I downloaded the latest driver from ati (9-3). Again I got a blank screen on reboot. Next I tried the same drive that works in Ubuntu, 8-8. This driver would not build due to dependency issues.
Finally I tried ati-driver-installer-8-12-x86.x86_64. This driver would install and it works.
I followed the procedure that Dredger shows. I used the untinstaller in /usr/share/ati to remove the non-working drivers. I installed from init 3 run level as root.

Linux linux-ma5q #1 SMP 2009-05-26 17:02:05 -0400 i686 athlon i386 GNU/Linux

system = Compaq 6715b

Hi Dredger,

I’ve done what you’ve suggested in the latest post. I do have an ATI Radeon 8450 card and I have used the 9.5 driver (just so that there is a 9.6 now, will use that for later tests). Despite downloading missing packages I still get the exact same error message as before. The file which can’t be deleted is “//usr/X11R6/lib/modules/dri/” (with the two slashes), but I’m not sure how that is relevant to my problem.