Blacklist для softupdate

Добрый день. Как известно xulrunner от 17 версии не поддерживает chmsee 1.99 и поэтому приложение не запускается (это проблема не OpenSuse, а xulrunner и chmsee вобщем). Я скачал пакет другой версии, и всё стало работать. Но теперь при команде zypper dup или zypper update всё время хочет обновить mozilla-js xulrunner. Как заставить zypper игнорировать эти два пакета?

zypper al mozilla-js
zypper al xulrunner

https://ru.opensuse.org/images/3/30/Zypper-cheat-sheet-2.pdf

А пункт “lock” в GUI Управление ПО у вас что, микрошрифтом набран?

Извините, что разочаровываю, но Yast’ом не пользуюсь

xandry](https://forums.opensuse.org/members/xandry.html) + 1

Судя по Вашему вопросу, зря. Потому что YaST позволяет не только сделать быстро то, что не очень хорошо знаешь, но и заодно узнать, как это делается в принципе.

…Yast’ом не пользуюсь

Дело хозяйское.
В противном случае не тратили-бы своё время на поиски ответа и вопросы в форуме.
Личное время дороже железяк (места на винте) и “религиозных убеждений”, по-моему.

Прошу прощение, по сути вопроса
zypper locks -список блокируемых пакетов
zypper addlock “пакет” -добавить блокировку пакета

А в общем, zypper help выводит список команд русским языком (по крайней мере в 12.2) :slight_smile:

ЗЫ.Яст и зиппер, по-моему, всего только инструменты.
Просто в разных случаях один удобнее другого.

Об этом и речь.
И есть два общих случая:

  1. если хорошо знаешь инструменты типа зиппера - проще пользоваться ими
  2. если не очень хорошо - мордами типа модулей YaST’а