Blacklist nvidia module

Hi all,

I just moved over from Kubuntu and am enjoying openSuse a lot so far. The only issue I’m having is blacklisting the nvidia module on startup. In /etc/modprobe.d/50-blacklist.conf I added “blacklist nvidia” but when I reboot and run lsmod it is still showing that it loaded.Am I missing something?


So unless you have installed the proprietary nvidia driver, no driver called nvidia yet exists to blacklist. The open source driver is called nouveau, which you may blacklist if trying to install the nVIDIA one, so you sound confused to me. Have a look at a couple of blogs on the subject:

Installing the nVIDIA Video Driver the Hard Way - Blogs - openSUSE Forums


LNVHW - Load NVIDIA (driver the) Hard Way from runlevel 3 - Version 1.10 - Blogs - openSUSE Forums

I would read through them before I said anything else and then lets clarify what you are really trying to do. The LNVHW can help uninstall the driver if loaded from terminal and you use YaST to uninstall it if installed the easy way from there.

Thank You,

Sorry I posted in a hurry. Here is what I have:
openSuse 12.3
Nvidia 313.26
Bumblebee 3.1
bbswitch 5.0

I have an Optimus setup so I have bbswitch to disable the nvidia card when it isn’t in use. The problem is that at boot the nvidia module gets loaded so it can’t disable the card. If I rmmod nvidia I can disable the card and everything runs as expected from there. I am just trying to keep the nvidia module from being loaded at boot so bbswitch can disable the card without me fiddling with it every time.

So really you have an Optimus/Bumblebee problem, not a nVIDIA driver problem as I thought Bumblebee allowed you to switch back and forth. Unless you stick with one setup or the other, I would use the rmmod command until you figured out how to use Bumblebee. Your message title does not reflect the fact that you are using Bumblebee on an Optimus setup which is why trying to remove the nVIDIA kernel module, which you must load on purpose, makes no sense.

Thank You,

I was also in the belief that blacklisting nvidia and running mkinitrd would solve this problem,. It didn’t! Go to yast>system>/etc/sysconfig editor>System/kernel>initrd_modules, there you probably have it, delete the nvidia entry. How it ends up there I don’t know, probably the Nvidia installer adds it. However the nvidia card is still powered on at boot, it will only power off after running optirun or primusrun once. But that’s next problem to solve.