Black windows with Compiz

I’m using openSuSE 11.1 with Compiz 3D desktop on a ThinkPad R61.
I get black windows depending on the size. When I resize them smaller, the content is shown, after resizing bigger, it turns black again.

I expect Compiz to cause the trouble, but don’t know where to start troubleshooting. So far, I tried to switch off certain Compiz plugins with no result.
Any hints?

Some detail about my system:

  • openSuSE 11.1 x86_64
  • kernel-xen 2.6.27.21-0.1.2
  • Gfx card: Nvidia Quadro NVS 140M
  • xgl 11.1-71.1
  • compiz 0.7.8-46.1 (from Compiz repo)

Thanks for any suggestions.

It may not seem obvious, but turn Compiz off completely and see what happens.

What’s with the xen kernel? Are you actually using xen?
We could do with knowing if you are kde3/4 or gnome?

I use XEN, that’s why I use kernel-xen. :wink:

Using the default kernel, the problem doesn’t occur. Same, when using kernel-xen and disabled 3D desktop.

Used software update:

  • gnome 2.24.1
  • nvidia-gfxG02-kmp-default 180.51_2.6.27.21_0.1-1.1
  • nvidia-gfxG02-kmp-xen 180.51_2.6.27.21_0.1-1.1
  • x11-video-nvidiaG02 180.51-1.1

Found an option in Compiz config (ccsm) Display Settings stating output to be 640x480+0+0. Changed it to 1400x900+0+0. No more black windows so far…

Problem remains. :frown:

Disabling 3D desktop helps, but I’d like to use compiz and xen…

I’m not sure I can offer any further advice as I very limited experience with xen.

bump :silly:

Use Nvidia driver with Xen - openSUSE

I think this requires you to compile your own nvidia driver. But if you haven’t built your graphics driver against the XEN kernel I would be to think it would yield the same results as not building it against the default kernel. So you can give that link a try.

Good Luck,

Ian

As far as I understand, the nvidia driver from nvidia-gfxG02-kmp-xen package is built agaist xen kernel from kernel-xen package? :question:

If so, compiling the nvidia module myself would/should give the same result as shipped with nvidia-gfxG02-kmp-xen package.

If you google the title of this thread you should get to an Ubunutu bug.

Then also you get to Compiz that has a bit, now if iirc the compiz seems to think this is related to the driver and can be partially solved by using indirect rendering…

But the bug report is more interesting they seem to imply it is the GPU running out of memory, now I did try but couldn’t replicate it. They also have several links to various distro’s including one to the suse wiki which has various additional lines to add to xorg.conf(With a disclaimer shouldn’t be needed in later drivers). I have to admit I think perhaps the Ubuntu bug report is correct and it is a memory problem but having not experienced can’t really tell.

Is it possible to rule out the kernel, does it do it with other distro’s maybe you can have 2 kernels?(Unsure not something I play with)

Thanks a lot! This lead my to the right direction.

Followed these instructions:
Fix the Black Windows Bug with nVidia cards! - Compiz Community Forums and added some options to my xorg.conf.

Compiz behaves better, but when I open too many windows, they start to become black again. So I asume, it’s a thing like out-of-memory.
I’ll fiddle with the xorg.conf options and module loading options a bit.

Thanks so far. :slight_smile:

Here is the ubuntu bug report sounds like you’re almost confirming it. Having a 512mb card I struggled to confirm it. Though don’t think the light weight distro/DE helped either I tried with about 80 windows and finally gave in.

Think this quote says it really…

Those instructions just raise the threshold a bit at best

In thread you’ll find the link to Suse wiki but think you’ve probably covered them any way.