black screen

Yesterday i selected the option : ‘enable desktop effects’ and now
when suse boots i get a black screen and nothing happens further.
I think my monitor is out of range. How do i go back to the previous settings?

If you’re talking about Compiz effects, I think they should automatically revert to “disabled” after a reboot. If anything else has been screwed up, you may try running sax2 -r from a virtual terminal.