Black screen


Just installed openSuSE 11 i386 on my Dell Laptop but I am just getting a black screen during boot.

I select the openSuSE option on the boot menu, then the bar under the openSuSE logo goes about halfway and then it just comes up to a black screen.


Ok, something is not right with your graphics configuration. Try booting into failsafe (console) mode first (select via grub menu). Log in as root and enter root password when prompted. Then type


This should bring up a utility to try and detect and configure your graphics system and display. If you have more problems post the details here.

A useful how to.

On Failsafe I get a continuous loop of the same lines of text:

I’ve seen the same bug reported in ubuntu from a Dell Latitude D630 user:

Which model Dell laptop do you have?

Its a D531:

AMD Turion64x2
ATI Radeon Mobility x1200 (or some number, I forget :P)

It ran Ubuntu 8.04 and 8.10 fine for a while until I broke it and was persauded to try Suse (haven’t used it in years).

I checked the openSUSE laptop HCL, and this laptop is reported as working with no special boot codes. Before wasting too much time on searching (for a special boot code) it would be worth while getting confirmation from you that you ran the media check prior to installation. Can you confirm that? Did the CD pass the media check?

It was a net install.

But it does it when I install from a DVD too.

If I delete the “acpi=off” in the failsafe line, it boots, but boots into a GUI with minimal graphics settings, i.e. 800x600 res.

Well done in sorting that (ie discovering that removing “acpi=off” is beneficial). The rest from here on end should be relatively easy, albeit a bit time consuming.

As you have noted, booting to failsafe adds a bunch of options that are not present in a normal boot. What is useful for you now is to figure out, precisely which fail safe boot option enables you to boot? You can do that by trying to boot normally, using each one of those boot codes at a time. Once you figure out the boot option that works for you (for a regular boot) you can add that boot option to an appropriate location in your /boot/grub/menu.lst file (and if you don’t know how to do that, then one of the users on our forum can explain that).

Now reference your 800x600, my guess is you are either using a VESA driver or you are using an open souce GL driver. You can figure out what driver by typing in a gnome-terminal or a kde konsole:grep -i driver /etc/X11/xorg.confif it says vesa, it is a vesa driver. If it says radeon or radeonhd, it is an open source driver for an ATI graphic device. You can also learn more by typing:xrandrwhere (from “man xrandr” ) Xrandr is used to set the size, orientation and/or reflection of the outputs for a screen (in this case the reflection of the outputs).

There is a good possibility both the vesa and the opensource GL driver support a higher resolution than 800x600. So if you reboot your PC to run level 3 (at the grub boot menu, where you removed “acpi=off” type the number “3” (no quotes) such that the 3 is added to the options line. This will boot you to a text login (known as “run level 3” ). Log in as a regular user. Then once logged in, type “su” to get root permissions (enter root password). Then back up your /etc/X11/xorg.conf file with:cp /etc/X11/xorg.conf /etc/X11/xorg.conf.backupThen if you learned from above that you are using “radeon” as your driver, try to see if you can default to a higher graphic resolution by typing with root permissions:sax2 -r -m 0=radeon
If that seems to run ok then it should exit you back at a text prompt. Then type “exit” (no quotes) to get rid of root permissions. Type “whoami” to confirm you are no longer root. Type “exit” again if necessary. Then to test X window type “startx” (no quotes) as a regular user (DO NOT DO THIS AS ROOT !! ) . If that looks good, open a gnome terminal or kde konsole and type:su -c ‘shutdown -r now’ to reboot and test your graphics without going through run level 3.

Okay, to boot I have to use the “x11failsafe” option.

the grep command gave me: “Vendor Name ATI Proprioetry Driver” and “Driver fglrx”.

Xrand told me the lowest, current and highest res would be 800x600.

The sax2 command didn’t give me any more resolution options either :frowning:

That was a surprise to me.

“fglrx” was also a surprise to me. I think “fglrx” is for a proprietary driver, and you have not installed a proprietary driver.

I do not know the limitations that are imposed when one has to use the “x11failsafe” option.

Out of curiousity, if you boot to run level 3 (per the instructions above), what happens if with root permissions you backup your xorg.conf file (per the instructions above) and then also with root permissions you type:sax2 -r -m 0=radeonDo you get better resolution then? Again, as noted above, you need to type “exit” to get rid of root permissions and then type “startx” to test your graphics. Also “xrandr” will tell you a bit about your graphics with the radeon driver in place.

If the radeon driver works, can you still boot (with the radeon driver) if you remove the “x11failsafe” option ?

If that does not seem to help, you can also try:sax2 -r -m 0=vesaand again see what sort of resolution you can get with the vesa driver. … (ie same as above).

Good luck.

Okay, It copied my config file fine.

I ran the sax2 -r -m 0=radeon command and it gave me errors:

SaX: startup

xc: sorry could not start configuration server
xc: for details refer to the log file:

xc: abort...

The SaX log says:

*goes through a lot of ATI graphics cards in a list*
(II) Primary Device is: 01:05:0
(--) Assigning device section with no busID to primary device
(EE) No devices detected.

Fatal server error:
no screens found

And so it defaulted back to VESA.

At this point xrandr is showing 4 resolutions:
1152x864 60.0*
1024x768 61.0
800x600 61.0
640x480 60.0

It can now boot without the x11failsafe flag and defaulted to 1152x864 resolution.

So it is definitly getting there!

Now, all I need to do is get my full 1440x900 resolution.

Got it all working now! :slight_smile: I was able to download the Integrated chipset driver for the x1250 from the ATI site, and then followed “The Hard Way” on the openSUSE ATI Driver HOWTO. Now it fully works! :slight_smile:

Boots with no x11failsafe flag, running at 1440x900 resolution at 16.5m colours, never have I appreciated 1440x900 so much! Its so crisp! :stuck_out_tongue:


It appears the Radeon openGL driver does not work well with your x1250.

Thanks for the help by the way! :slight_smile: I Don’t think I would have ever got it working without you :stuck_out_tongue: