Black screen with working cursor after login as user

I installed opensuse 11.4 without problem a week ago. Since then I’ve updated a few times. A few days ago I powered down my computer and the next morning when I booted it and tried to log into my user account it went through the motions and then became a black screen with working cursor. I’ve googled this and tried some of the advice given, like using the nomodeset option, or editing device-50.conf to use a different video driver, or running command Xorg-configure (in runlevel 3). I used nvidia’s config tool too without success.

I can log into the root account graphically just fine, so I’m stumped. I am using the nvidia video driver and KDE.

In runlevel 3, as my regular user account, when I try startx I get some errors like unable to copy xorg.conf.new to xorg.0.conf
(which I did manually as root and didn’t help)
It also said something like ‘try installing a different display manager’. No idea how to do that…

Anyone know what could cause this, how I could fix the display for my user account, or any steps to take to figure this out? Any help would be appreciated, thanks! :slight_smile:

Try creating a new user login
See if you can login with that

Perhaps also advise us as to:
.

  • exactly what graphic hardware is on your PC ?
    This you can find out by typing the command :

/sbin/lspci -nnk | grep VGA -A2

  • exactly what graphic driver is in use and was attempted to be loaded on your PC ?
    This you can find out by viewing the contents of the /var/log/Xorg.0.log file … For example on my PC with the nVidia proprietary driver I see many entries with lines starting with (==) NVIDIA(0) and (–) NVIDIA(0) … an EASY way to look at that file’s contents is to type:

cat /var/log/Xorg.0.log | less

and scroll back and forth to figure out what driver was attempted to be loaded, and press the key ‘q’ to quit.

Thank you for replying :slight_smile:
Yes, I created a new account and was able to login with that fine, same as root.

Thank you for your suggestions :slight_smile:
The output of


/sbin/lspci -nnk | grep VGA -A2

was:


00:0d.0 VGA compatible controller [0300]: nVidia Corporation C61 [GeForce 7025 / nForce 630a] [10de:03d6] (rev a2)
        Subsystem: Biostar Microtech Int'l Corp Device [1565:1405]
        Kernel driver in use: nvidia

and from


cat /var/log/Xorg.0.log | less

I got:


...
[361606.286] (II) NVIDIA GLX Module  290.10  Wed Nov 16 19:49:02 PST 2011
...
[361606.294] (II) LoadModule: "nvidia"
[361606.294] (II) Loading /usr/lib/xorg/modules/updates/drivers/nvidia_drv.so
[361606.295] (II) Module nvidia: vendor="NVIDIA Corporation"
[361606.295]    compiled for 4.0.2, module version = 1.0.0
[361606.295]    Module class: X.Org Video Driver
[361606.295] (II) NVIDIA dlloader X Driver  290.10  Wed Nov 16 19:29:07 PST 2011
[361606.296] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[361606.301] (--) using VT number 7

[361606.324] (II) Loading sub module "fb"
[361606.324] (II) LoadModule: "fb"
[361606.325] (II) Loading /usr/lib/xorg/modules/libfb.so
[361606.325] (II) Module fb: vendor="X.Org Foundation"
[361606.325]    compiled for 1.9.3, module version = 1.0.0
[361606.325]    ABI class: X.Org ANSI C Emulation, version 0.4
[361606.325] (II) Loading sub module "wfb"
[361606.325] (II) LoadModule: "wfb"
[361606.326] (II) Loading /usr/lib/xorg/modules/libwfb.so
[361606.326] (II) Module wfb: vendor="X.Org Foundation"
[361606.326]    compiled for 1.9.3, module version = 1.0.0
[361606.326]    ABI class: X.Org ANSI C Emulation, version 0.4
[361606.327] (II) Loading sub module "ramdac"
[361606.327] (II) LoadModule: "ramdac"
[361606.327] (II) Module "ramdac" already built-in
[361606.327] (==) NVIDIA(0): Depth 24, (==) framebuffer bpp 32
[361606.327] (==) NVIDIA(0): RGB weight 888
[361606.327] (==) NVIDIA(0): Default visual is TrueColor
[361606.327] (==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
[361606.327] (**) NVIDIA(0): Enabling 2D acceleration
[361606.881] (II) NVIDIA(GPU-0): Display (Dell E151FP (CRT-0)) does not support NVIDIA 3D
[361606.881] (II) NVIDIA(GPU-0):     Vision stereo.
[361606.883] (II) NVIDIA(0): NVIDIA GPU GeForce 7025 / nForce 630a (C61) at PCI:0:13:0
[361606.883] (II) NVIDIA(0):     (GPU-0)
[361606.883] (--) NVIDIA(0): Memory: 262144 kBytes
[361606.883] (--) NVIDIA(0): VideoBIOS: 05.61.32.31.07
[361606.883] (--) NVIDIA(0): Interlaced video modes are supported on this GPU
[361606.883] (--) NVIDIA(0): Connected display device(s) on GeForce 7025 / nForce 630a at
[361606.883] (--) NVIDIA(0):     PCI:0:13:0
[361606.883] (--) NVIDIA(0):     Dell E151FP (CRT-0)
[361606.883] (--) NVIDIA(0): Dell E151FP (CRT-0): 350.0 MHz maximum pixel clock
[361606.883] (**) NVIDIA(0): Using HorizSync/VertRefresh ranges from the EDID has been
[361606.883] (**) NVIDIA(0):     enabled on all display devices.
[361606.883] (II) NVIDIA(0): Assigned Display Device: CRT-0
[361606.883] (==) NVIDIA(0): 
[361606.884] (==) NVIDIA(0): No modes were requested; the default mode "nvidia-auto-select"
[361606.884] (==) NVIDIA(0):     will be used as the requested mode.
[361606.884] (==) NVIDIA(0): 
[361606.884] (II) NVIDIA(0): Validated modes:
[361606.884] (II) NVIDIA(0):     "nvidia-auto-select"
[361606.884] (II) NVIDIA(0): Virtual screen size determined to be 1024 x 768
[361606.885] (--) NVIDIA(0): DPI set to (83, 84); computed from "UseEdidDpi" X config
[361606.885] (--) NVIDIA(0):     option
[361606.885] (--) Depth 24 pixmap format is 32 bpp
[361606.897] (II) NVIDIA(0): Setting mode "nvidia-auto-select"
[361607.023] (II) Loading extension NV-GLX
[361607.059] (==) NVIDIA(0): Disabling shared memory pixmaps
[361607.059] (==) NVIDIA(0): Backing store disabled
[361607.059] (==) NVIDIA(0): Silken mouse enabled
[361607.060] (==) NVIDIA(0): DPMS enabled
[361607.060] (II) Loading extension NV-CONTROL
[361607.060] (WW) NVIDIA(0): Option "TwinViewXineramaInfoOrder" requested "DFP", but no
[361607.060] (WW) NVIDIA(0):     such display device could be found, or all display devices
[361607.060] (WW) NVIDIA(0):     by that name are currently unavailable.
[361607.060] (WW) NVIDIA(0): Option "TwinViewXineramaInfoOrder" requested "TV", but no such
[361607.060] (WW) NVIDIA(0):     display device could be found, or all display devices by
[361607.060] (WW) NVIDIA(0):     that name are currently unavailable.
[361607.060] (II) Loading extension XINERAMA
[361607.061] (II) Loading sub module "dri2"
[361607.061] (II) LoadModule: "dri2"
[361607.061] (II) Reloading /usr/lib/xorg/modules/extensions/libdri2.so
[361607.062] (II) NVIDIA(0): [DRI2] Setup complete
[361607.062] (II) NVIDIA(0): [DRI2]   VDPAU driver: nvidia
[361607.062] (==) RandR enabled
...

Any ideas? :slight_smile:

iturner5150, if you log in as a normal user and type this in, what do you get?

sudo /sbin/init 5

Thank You,

Thank you for the reply :slight_smile:

When I try that nothing happens. I am prompted for root password and I enter it and just get a command line after that. No output, nothing I can discern has happened

Edit: To be clearer, I booted into runlevel 3, and logged into my ‘problem user account’ and used the command you specified. I hope I did what you were asking correctly.

Thanks again

Proceed to login with your normal account
SO you are logged in and at a black screen logged in with the prompt.

Now type:

mv .kde4 .kde4-old

Now reboot:

su -
<password>
reboot

Try logging in normally

I’ll be ****ed, that worked! Thank you very much for your help! :slight_smile:
It looks like I lost a few desktop settings, but everything else seems just as I had it! So happy… :slight_smile:

The settings are like new
Your old settings are in the hidden folder .kde4-old which is in your home dir
Only bring back settings for applications like: konversation, kmail, etc… (And then, only if you know how)
If you can live with it as is, do so.

Happy to help