Black Screen while installing Suse 11.2

I believe that the installation has two steps, one that loads all the programs, reboots and then the second one is when it tries to download updates and completes the whole installation.

I can’t get to the second step. It just shows a black screen and the mouse pointer

I am pretty sure it is my motherboard but I hope there is a fix somewhere, I was able to install a older version of suse on this motherboard before(10.x), but had problems with the Win/Linux boot so now I am trying to use it only for Linux with no luck

Pentium 4 3GHz
Motherboard: ECSRC410L/800-M
with ATI Radeon Express 200 integrated video card(which might be the problem)

Thank you


Can you boot to the command line? Press 3 at the boot menu.

this might help. I definitely suspect the video card

openSUSE Graphic Card Practical Theory Guide for Users - openSUSE Forums


the ATI card is probably the cause, try booting into runlevel 3, by
entering a 3 at the grub menu, then login and type:

su -


sax2 -r -m 0=vesa

this should get you t a working, but not graphically great system.
If it does work at least you know the cause and can try the open source
Radeon driver, which should be a lot better.

Barry Nichols

Hello guys :slight_smile: the problem was fixed while writing a reply to you

Please read what I was gonna write in case is somehow good to know

pressing 3 didn’t work

by the way, in order for me to get some progress during the installation, I press Ctrl C in a moment when everything is stuck. Maybe that is something wrong but is the only way the system doesn’t get stuck in the green screen with the opensuse logo and the process bar (stuck in about 5%)

I hope my explanation is understandable (ESL)

every time I start the PC and after I press Ctrl C I get a pop up message that says: “the installation has failed, would you like to continue (you might have to write some additional information)” I press yes and the black screen with the mouse pointer comes up

I can move the mouse if that helps

when I was writing this I thought: what if I press NO and then I tried and it worked out :slight_smile:

I am feeling good, for now I could login as root and I can see the desktop

thank you for your replies

You should NOT log into a GUI as root!!! You can damage your system. :frowning:

gogalthorp wrote:
> You should NOT log into a GUI as root!!! You can damage your system.

to expand a bit on the why and how:

doing so 1) opens you up to several different security problems, 2)
too many too easy ways to damage your system no matter how careful
your actions (example: just browsing in your home directory while
logged into KDE/Gnome/etc as root can lock you out later as yourself
due to permissions damage), 3) and, anyway logging into KDE/etc as
root is never required to do any and all administrative duties…

so, always log in as yourself, and “become root” by using a root
powered application (like YaST, File Manager Superuser Mode) or using
“su -”, sudo, kdesu, gnomesu in a terminal to launch whatever tool is
needed (like Kwrite to edit a config file)…read more on all that here: