Black screen when switching to any virtual console

Hi all,

I’ve a Sony Vaio VPCS12L9E with Nvidia GeForce310M with OpenSuse 11.4 64bit.

I’m using lastest Nvidia proprietary drivers (x86_64-260.19.44) and everything seems working correctly, virtual consoles apart.

When I switch to any of virtual console (ALT-CTRL-Fx) I get black screens.

The console is present because I can login and executing commands (blind login), and by switching ALT-F7 I can return in graphical mode.

I’ve tried to use vga=normal as boot option in grub without any result.

Any suggestion to solve such annoying behavior?


Hmm… I’m speculating here, so… YMWY (your mileage WILL vary :))

In console the resolution/frequency/bitmode may be different, I think, and whatever driver is controling it (fbdev?) may be getting it wrong.
If you boot straight into level 3 do you have this problem?
If your monitor have an auto setting button, did you try it (or is this Vaio a laptop)?
If you try a liveCD do you have this problem also?

I have no idea how to change fbdev settings, I think it’s part of X, perhaps Xorg.0.log (where it log the various driver tests) will give you a clue.

I don’t suppose there’s any BIOS setting that affect this?

You are experiencing a typical problem with Nvidia drivers. I have scourged and scourged and ran across some “solutions” that have never worked for me.
I think what brunomcl is talking about was one of those “solutions” - it didn’t work for me, but feel free to explore it.

Boot with the kernel parameter nomodeset.
But be sure to use NVidia drivers (not the ones that come with the opensuse 11.4 installer.

I had the same problem and that’s the way I fixed it, but with ATI drivers. I also had to change the KDM RC file for other reasons.

Unfortunately your suggestion doesn’t help me.

But I tried to use Nouveau driver and virtual consoles run perfectly. Therefore I suppose it’s a Nvidia issue.

Booting into level 3 don’t present this problem.
It’s a Vaio laptop.

I’ll try a liveCD, but in the meantime I’ve discovered the Nouveau driver is not affected by this problem and virtual consoles run perfectly.
But it has many others…

As long as you use anything but Nvidia you won’t experience the problem.

I figured out how to get the virtual consoles back using a Nvidia driver. You have to install uvesafb and let it replace vesa.
Some Arch instructions: that worked for me.